WordPress.org

Ready to get started?Download WordPress

Forums

Permalink problem! (6 posts)

  1. Anonymous
    Unregistered
    Posted 5 years ago #

    Hi...

    I'm A COMPLETE newbie, speaking that I don't know whats in the cracks of wp coding.

    But I don't know enough to resolve this problem I'm having.

    I would like my posts to show up as

    /%category%/%postname%/

    and not the default (?page_id=123456). But when I change it, I get a 404 error page/page does not exist sort of thing.

    I haven't got the htaccess file, and I don't know how to get it, and same for the mod_rewrite thing.
    I need a resolution! (As to why this is happening and how to fix the problem).

    The site is http://WWW.DEVAMSHA.COM btw.

    Thanks is adv.,
    designerd.

  2. ladycrow
    Member
    Posted 5 years ago #

    Editing the htaccess is often necessary when changing permalinks.

    In your ftp program, you'll need to enable showing of hidden files. I can't say for sure where this may be but check your settings/options.

    Once you enable this, you may have a .htaccess file in your "wp" (base) directory which you can edit to add the part WP tells you to add after changing permalinks.

    If not, on your computer create an htaccess.txt and paste into it the changes specified. Upload it to the wordpress directory then rename it to .htaccess

  3. Anonymous
    Unregistered
    Posted 5 years ago #

    RE: ladycrow,

    That's the bit I'm kinda stuck on...., what do I put in the htaccess.txt file? I've been told to put

    Error 404 htaccess

    into it but it failed to work.

  4. Chris_K
    Member
    Posted 5 years ago #

    Well, that's a new one on me...

    Have you checked our Permalinks page in the documentation? Lots of trouble-shooting info there.

  5. ladycrow
    Member
    Posted 5 years ago #

    designerd - that's what the dashboard instructed you to put?

  6. Anonymous
    Unregistered
    Posted 5 years ago #

    ladycrow - no, it's what a friend recommended to me.

    handysolo - thanks, that's a new piece of advice...I was always looking at a different permalink page - but still on the WP documentation.

    P.S sorry for not quickly replying, I was trying to fix it and fell asleep! :)

Topic Closed

This topic has been closed to new replies.

About this Topic