WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink Problem (14 posts)

  1. matt3161
    Member
    Posted 1 year ago #

    I've just discovered I have a problem with my permalinks - If i select anything other then default, all the links on my site stop working.

    Site is blog.invitationsonly.com.au - permalinks are currently set to default.

    I would like to be using /%postname%/ but as soon as I select it from the permalinks menu, all the links stop working.

    Anyone experienced this before/have any suggestions?

    Thank You!

  2. Check if mod_rewrite is loaded on your web server and it's active on your WordPress directory.

    For your WordPress directory you should have something like this in your Apache2 configuration.

    <Directory>
              AllowOverride All
    </Directory>

    If you make any changes to any configuration files make sure you make a backup copy first.

    Once the mod_rewrite module is active and allowed for that directory then permalinks should work for you.

  3. matt3161
    Member
    Posted 1 year ago #

    Thanks for that, unfortunately I have no idea where to find the apache 2 configuration... or check if mod_rewrite is loaded on the server... Here's a screenshot of the root directory if it helps?

    http://screencast.com/t/xyOWQaZPtqCb

    I'm not really fluent with this stuff - Could you explain in newbie language how to check if mod_rewrite is loaded on the server?

    Thank You

  4. matt3161
    Member
    Posted 12 months ago #

    I have spoken to my developers and the support crew at the hosting company, they have looked into the issue and say that mod_rewrite is active and working fine.

    The issue still persists...

    Any other suggestions?

  5. Krishna
    Volunteer Moderator
    Posted 12 months ago #

    Deactivate all plugins, revert to Twenty Twelve theme and try to reset permalinks.

  6. matt3161
    Member
    Posted 12 months ago #

    tried that, still same issue...

  7. Krishna
    Volunteer Moderator
    Posted 12 months ago #

    You are running WordPress 3.5.1. Update WordPress to the latest version and then try changing permalinks.

    BTW, have you checked your apache 2 configuration as Jan advised above?

  8. matt3161
    Member
    Posted 12 months ago #

    Yes I checked apache 2 configuration as Jan advised, I have also updated to latest wp version including all plugins. Problem still exists.

  9. Krishna
    Volunteer Moderator
    Posted 12 months ago #

    Something strange is going on as I see your permalinks are set to custom but they do not work. Same is the case with read more link. Can you check what you have in your .htaccess file and copy and post it here?

  10. matt3161
    Member
    Posted 12 months ago #

    Options +FollowSymLinks
    RewriteEngine On
    Options All -Indexes
    RewriteBase /
    RewriteCond %{HTTPS} !^on$
    RewriteRule (.*) https://invitationsonly.com.au/$1 [R,L]
    RewriteRule ^([a-zA-Z0-9_-]+)$ categories.php?pageurl=$1
    RewriteRule ^([a-zA-Z0-9_-]+)\.html$ cms.php?cmslink=$1&id=$2
    RewriteRule ^([a-zA-Z0-9_-]+)/([a-zA-Z0-9_-]+)$ product.php?cateurl=$1&producturl=$2
    php_value memory_limit 128M
    php_value upload_max_filesize 128M
    php_value max_input_time 10000
    php_value post_max_size 64M
    php_value max_execution_time 200000
    php_flag magic_quotes_gpc off
    php_value date.timezone "Australia/Melbourne"
    ErrorDocument 404 https://invitationsonly.com.au
    ErrorDocument 403 https://invitationsonly.com.au
  11. rondelw
    Member
    Posted 12 months ago #

    I'm having the same problem...can someone running the latest version of WP with a custom permalinks share what their .htaccess is?

    Here's mine:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    This is a brand new install with only a few plug ins

  12. matt3161
    Member
    Posted 12 months ago #

    Hi All, I found a guy on Fiverr.com who fixed the issue in minutes.

    Check the attached image., Iine no 6. Which redirect all /filename to the host URL .

    So the wp - permalinks was not working (Line no 18-27).

    Now I removed line no 6. Then Fine.

    http://i879.photobucket.com/albums/ab353/Matt_Rubenstein/htaccess_zpscd7caa1e.jpg

  13. rondelw
    Member
    Posted 11 months ago #

    I still have not been able to fix this...any ideas anyone?

  14. Krishna
    Volunteer Moderator
    Posted 11 months ago #

Topic Closed

This topic has been closed to new replies.

About this Topic