WordPress.org

Ready to get started?Download WordPress

Forums

CM Tooltip Glossary
Permalink problem (10 posts)

  1. hrdo2001
    Member
    Posted 1 year ago #

    I have set up a glossary/dictionary and I think i have a permalink problem. I can publish a glossary term but somehow it is not connected to the "glossary page." Also, I can't get the "glossary page" to list my terms despite the fact that I have applied the correct page id. Any suggestions? Thanks!

    I can't provide a link because my sites in maintanence mode.

    http://wordpress.org/extend/plugins/enhanced-tooltipglossary/

  2. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    Did you try to update the permalinks just by pressing the update button once or twice. Magicly this sometimes helps

  3. hrdo2001
    Member
    Posted 1 year ago #

    Yes. I'm unsure at this point if it's a problem with the plugin, my theme, or both. I have checked the page id, made sure the page is a parent page, named my permalink appropriately, and resaved the permalink settings but still no index. The permalink of my parent index is http://oralallergysyndromenetwork.com/glossary and the terms permalink are http://oralallergysyndromenetwork.com/glossary/term yet when you view the breadcrumbs of where the parent index it reads Home:OASN Glossary and when you view a terms it reads Home:Glossary:Term. For some reason, despite the fact the permalinks match, their breadcrumbs are different and they aren't linking. Unfortunately I know very little about html and css coding and am unsure of how to approach this issue. Any suggestions would be appreciated.

  4. schwipps
    Member
    Posted 1 year ago #

    I think I encounter the same problem that you do : I can't get the glossary's permalink modification work.
    If I leave "glossary", everything works.
    However, if I set it up to something else, the permalink do are modified on the admin-side, but not on front. The only way to get to the definition is to replace the new word by the default one : glossary.

  5. mojonek
    Member
    Posted 1 year ago #

    I have the same problem (+ translation)
    :(

    As the "Glossary Permalink" is empty - everything works.
    As I type 'xyz' - I have a problem and the message "404 - Page Not Found"

    Original http://www.DOMAIN.COM/Glossary/Term1 - everything works.

    with 'xyz' in the "Glossary Permalink"
    http://www.DOMAIN.COM/xyz/Term1 - is Error # 404: (

    How do I change this parameter?
    I do not want to use the "glossary" in the / directory.

    P.S.
    Great plugin ;)

  6. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    @mojonek, @schwipps - We cannot really reproduce your problem. For a term description permalink we rely on WordPress core mechanism (slug for custom post type). Could you provide some address where we can check and debug that issue? Could you also check if changing 'with_front' to true on glossary.php line 70 and if saving permalinks (settings->permalinks) changes anything?

    @hrdo2001 - Parent index is actually a static page with the title and permalink as specified on "Pages" panel. So term pages are in fact independent from that index and have separate structure. To tell you what you can do to alter breadcrumbs display on term page, you would need to send us what do you use for generating breadcrumbs - is it some plugin or is it in theme? If so, what is its name?

  7. hrdo2001
    Member
    Posted 1 year ago #

    My breadcrumbs are generated by my theme: Udesign. As for my Glossary index the link is http://oralallergysyndromenetwork.com/glossary/ and it is showing "page not found." My page id is pointing to the right place according to settings. Thanks!

  8. schwipps
    Member
    Posted 1 year ago #

    @Creative Minds : I've sent you a test address through your website form. Thanks

  9. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    didn't receive

  10. schwipps
    Member
    Posted 1 year ago #

    Too bad ! This website is still in developpement, and I don't want to let it go public now.
    How can we proceed ?

    [ Please do not bump, that's not permitted here. ]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags