WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink problem (32 posts)

  1. Snowyn
    Member
    Posted 1 year ago #

    No one has replied to my previous post about this. I'm wondering if the problem is completely weird/unique. Even if that's true, I need some ideas on how to go about solving it.

    Permalinks are working on some pages and not others. It's not the htaccess file (which is identical to the one recommended under Permalinks page). It's not my theme. The problem also occurs using twentyten.

    The problem behavior is: for some pages, clicking on a link with the permalink (eg, http://mydomain.com/pretty-permalink) takes you to the page. For other pages, it takes you to Error-404-page-not-found.

    Can anyone suggest ways of diagnosing and fixing this problem?

    Thanks (desperate webmaster here).

  2. James Kirk
    Member
    Posted 1 year ago #

    Hey Snowyn,

    Sounds pretty frustrating. Are you able to post some links to your site so we can check things out there?

    Thanks!

  3. Snowyn
    Member
    Posted 1 year ago #

    Very frustrating. Site is
    http://phoenixhealingarts.net

  4. Snowyn
    Member
    Posted 1 year ago #

    What works: home, resources, health-concerns page and subpages.

    What 404's: about and subpage, services and subpages, contact.

    I'm wondering if maybe something in the database that keeps track of the permalinks got messed up.

  5. James Kirk
    Member
    Posted 1 year ago #

    Very strange indeed! What do you have on your "Settings -> Permalinks" page? What have you chosen for the sites Permalinks there?

  6. Snowyn
    Member
    Posted 1 year ago #

    /%category%/%postname%

  7. Snowyn
    Member
    Posted 1 year ago #

    And James -- thanks so much for your assistance. (Going a little crazy here.)

  8. James Kirk
    Member
    Posted 1 year ago #

    Been there, gone crazy myself, Snowyn! No worries.

    I've seen some issues on researching your challenge but nothing quite "exactly" like yours.

    Have you tried reverting to the "default" permalink structure (http://phoenixhealingarts.net/?p=123) to see if you are able to access those currently 404ing pages? If you've not, try making that change for a hot second, save and see what happens. Then go back to your preferred permalink structure of http://phoenixhealingarts.net/category/postname.

    Fingers crossed!

  9. temp4845
    Member
    Posted 1 year ago #

    This is unreal, I just came in here to see if anyone else has this problem. I have been working on it for two days. It seems like when I updated WP this started to happen, not sure but about that time.

  10. temp4845
    Member
    Posted 1 year ago #

    This is also slowing my PC down because as long as I am in WP my browser keeps looking for my site. Oh I forgot to put that in here. http://www.temp.lowercostelectricityprovider.com Also, this page I was working on (is not my home page). That is fine, if I could just get it to not 404 I can easily rebuild it. It is only a one page website. Thanks ahead of time for the help

  11. Snowyn
    Member
    Posted 1 year ago #

    Hi James,

    Yup, tried that. When going back to default page numbers, (a) I have to use the default twentyten theme in order to see them, but (b) yes, they are all there, visible, and accessible through the navigation.

    However, even in the twentyten theme, going back to permalinks I get the server 404s.

    Tried this at least twice, maybe three times. I've also checked the htaccess file in both situations. When I go back to default page numbers, htaccess returns to its "blank" variety. Shifting back to the custom permalink, htaccess becomes

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    which is identical to what WordPress says it should be. That is, I'm assuming it makes no difference about the blank line above # END WordPress.

    I'm now looking in the database to compare working pages with nonworking pages to see if there's anything weird there. So far, not really, but it's slow slogging...

  12. James Kirk
    Member
    Posted 1 year ago #

    @Snowyn Yeah, Apache will disregard the white space/blank line after the closing bracket, IfModule, so no worries there.

    Must admit, you've got me pretty stumped here! Do post back if you find any general (or specific) weirdness trudging through that sloggy database of yours ;)

    Apologies for not being more help :(

    @temp4845 The www is keeping anything from showing up on your temp site at all. But of course, just removing that then displays your 404 page :(

    Do you have WordPress Multisite set up? Or is this a single WP install in the "temp" subdomain? Also, do you have your DNS set up correctly to point the subdomain requests to the proper directories on your server?

    The reason I ask is because pinging the "temp" subdomain site gives me a different IP number than pinging the TLD site (lowercostelectricityprovider.com).

  13. Snowyn
    Member
    Posted 1 year ago #

    @JamesKirk: Please keep helping me think about this. I did find a php file that shows what the permalinks are for each page -- and it shows them working correctly. (See below if you're curious.)

    http://stackoverflow.com/questions/3464701/export-list-of-pretty-permalinks-and-post-title

    There are no differences between the pages that get 404s and the ones that don't. I revised it to show me the guid in the database, and again, no differences. (That is, most pages show just the site url. Two pages add the page number to the basic url, but one of these has the 404 and one is behaving correctly.)

    I'm getting really stumped here. I guess my next step is to find out more about when/why a server 404 occurs in the first place. If you have more thoughts on what to think about next, I would Really Appreciate it!

  14. temp4845
    Member
    Posted 1 year ago #

    Wow you are way over my head James. I do have two wp sites but I have not started building the other one yet. DNS I know I should know what that is but I don't. It has been years since I have done anything like this and it is a HUGH learning curve for a 68 year old guy. I really appreciate you taking the time on these forums, I know you are doing it on your own time and I commend you for that.

  15. temp4845
    Member
    Posted 1 year ago #

    James I think I know what I did. You mentioned two wp sites got me to thinking. I did start on the other site and I downloaded WP, I think I may have two WP's installed on the same site. Is that possible? When I go into admin I see the site I want but when I click view site is when I get the page not found message.

  16. temp4845
    Member
    Posted 1 year ago #

    i would even start all over, the site is not hard to make, but I would like to figure out what I did wrong so I don't do it again.

  17. James Kirk
    Member
    Posted 1 year ago #

    @temp4845 68, 86 Just numbers! No worries.

    DNS: Domain Name Servers. The system the Internet uses to allow for domain names (your-site.com) to be used instead of making people remember IP numbers to get to your site (192.168.0.1).

    When you say "...installed on the same site." Do you mean on the same hosting account? Because if so and the "temp" site is just in a folder on the main sites directory, then you are going to have problems trying to get visitors to see the temp.your-site.com pages.

    If you mean something else, do share!

  18. temp4845
    Member
    Posted 1 year ago #

    Wow, I have a lot to learn. I use Go-Daddy and I thought I would have to install WP on each site. For instance one is ftworthenergy.com another is lowercostelectricityprovider.com and the third one is temp because go daddy thought I should have a temp untill I finish building it. Therefore I called go daddy support and asked them to activate (up-load) WP on ftworthenergy.com but I am already using it with WP and Catalyst is my template.

  19. temp4845
    Member
    Posted 1 year ago #

    I just noticed another thing, the page that comes up as it should IE. the one I am working on is temp.lowercostelectricityprovider.com/sample-page/

  20. James Kirk
    Member
    Posted 1 year ago #

    @temp4845 Looks like the temp home page is coming up as well. Does this mean your call to GoDaddy did the trick? Hopefully so!

  21. James Kirk
    Member
    Posted 1 year ago #

    @Snowyn Hey, have you tried creating new pages on your site recently? Wondering if any of them (all of them?) will 404 or work correctly.

    If not, try doing a test one and inserting it into your navigation menus (however you're doing that with this theme.)

    Also, I've been researching more and came across something likely unrelated dealing with Custom Post Types. But thinking it might be worth the effort to test.

    Try changing you permalink structure to removing the category section of the link. Realizing this likely has little to do with the pages, but it has me curious now.

  22. @Snowyn - Have you turned off all your plugins? This could be an issue with them

    @temp4845 - Since yours isn't a 3.5 problem, if you need more help go ahead and make your own post so we can help you better :)

  23. temp4845
    Member
    Posted 1 year ago #

    Well I will be darned, I did turn on the plugins about 1/2 hour ago. I tried it after that with no change I may have forgotten to refresh. You guys are awesome to do this on your own time. I can't thank you enough.

  24. James Kirk
    Member
    Posted 1 year ago #

    @Snowyn What Mika said :/

    Thought I'd already asked that. Upon review I realize it was another thread. Bad Jimbo :(

    LOL

  25. Snowyn
    Member
    Posted 1 year ago #

    @Ipstenu @JamesKirk, yes, I tried turning off all plugins. Didn't have that many in the first place. And no, that didn't work.

    However, I Got It Fixed = YAY YAY YAY.

    Talked to GoDaddy about these are generating server 404's and me = Not Happy Camper. Anyway, the HelpDeskPerson tried creating a new page, and yes it showed up. So ... I tried making a new Services page (meanwhile deleting the old one so I could have continue a permalink of "services"). So, while making a new page with different permalink was fine, trying to use the old broken permalink was not fine.

    So, what I did: edit the three broken permalinks (about, services, and contact into about-client-name, services-page, and contact-us) and voila, everything now worked just fine. Of course, I then had to go change any link on the site that used the old permalink url to the new permalink url. But now all is hunkey dorey, and it only took me about an hour to do it all.

    As to why those three permalinks broke in the first place and stayed broken? I have no idea.

    Thank you James and Mika!!

  26. James Kirk
    Member
    Posted 1 year ago #

    Good for you Snowyn!

    One thing I'd suggest now that you are "good" is to make sure you create redirects for the search engines. Do you have a Google Webmaster Tools account? If those former 404 pages were listed in the Google search index, they are going to show as broken. You'll want to get in there and make sure you show Google that you have "fixed" the problem.

    And you'll likely want to use a plugin like Redirection to point the old pages to their new, working counterparts. Or not, if those 404s don't show up in GWT!

    Cheers!

  27. Snowyn
    Member
    Posted 1 year ago #

    @JamesKirk, Thanks for the suggestion of Redirection. That looked like a good one to use, though I had not implemented it yet. I do have a Google Webmaster Tools account, though not on/with this site. I suppose I could add it in. Thanks again!

  28. Snowyn
    Member
    Posted 1 year ago #

    @James, BTW, do I need to redirect all the urls that had /services/something to /services-page/something? I'm guessing that would not hurt... and might be necessary.

  29. Snowyn
    Member
    Posted 1 year ago #

    Unfortunately, the redirects are not happening. I still get the 404s on those pages. Oh well.

  30. James Kirk
    Member
    Posted 1 year ago #

    The redirection plugin can be a little tricky to get just right. This is how you'd set up the redirect for the former About page:

    Source URL: /about/
    Target URL: http://phoenixhealingarts.net/about-mimi-rhys
    HTTP Code: 301

    Try that and see if they work for you.

Topic Closed

This topic has been closed to new replies.

About this Topic