WordPress.org

Ready to get started?Download WordPress

Forums

Permalink Pages Show 404 Error (13 posts)

  1. s1ade
    Member
    Posted 6 years ago #

    After messing around with htaccess files for a while, I finally managed to get pretty permalinks work for posts :) It was great not seeing that "index.php" or "?" in the address anymore.

    But now my pages don't work. When I click on the link to a page, the header, sidebar and footer all show up fine. But the main part just says "Error 404 - Not Found"

    Following the WordPress Codex on Permalinks, I cleared my htaccess file and then updated my permalinks. WordPress doesn't automatically fill in my htaccess file. I chmodded it to 666, but it just stays blank when I update. It never gives me any warnings or code to manually put in either. Not sure if this has anything to do with the page thing...I manually put in this code in my htacccess file to get permalinks for posts working,

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /tom/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /tom/index.php
    </IfModule>
    # END WordPress

    Any ideas? All I can seem to find is to "Update Permalink Structure," but it doesn't seem to be working. Thanks for your help.

  2. s1ade
    Member
    Posted 6 years ago #

    I forgot to mention there's Frontpage on the server, but I don't believe it's an issue because permalinks works ok for the posts. I tried all the Frontpage troubleshooting stuff, like adding the Options to other htaccess, but no go.

  3. Chris_K
    Member
    Posted 6 years ago #

    WordPress doesn't automatically fill in my htaccess file. I chmodded it to 666, but it just stays blank when I update. It never gives me any warnings or code to manually put in either.

    Just for grins, make your .htaccess read only, then re-visit Options -> Permalinks. At the bottom of the page does it now tell you what to add?

  4. s1ade
    Member
    Posted 6 years ago #

    Hopefully this makes you smile, I set it to 444, and it gives the me message

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    In my htaccess file though I have /tom and /tom/index.php, and that works for posts

  5. Chris_K
    Member
    Posted 6 years ago #

    That's odd. Is the blog itself in /tom? What are to two URL values at Options -> General?

    Oh, and for RewriteBase, do you have a trailing / on /tom/?

  6. s1ade
    Member
    Posted 6 years ago #

    The two URL values under Options -> General are:
    http://photopics.ca/tom
    http://photopics.ca/tom

    Yes there is a trailing slash at the RewriteBase, it looks like this:
    RewriteBase /tom/
    and the other one is:
    RewriteRule . /tom/index.php

    Thanks for trying to help me out with this.

  7. Chris_K
    Member
    Posted 6 years ago #

    If you (temporarily) change to the Default theme, does the problem persist?

  8. s1ade
    Member
    Posted 6 years ago #

    When I go to the Theme Editor, the WordPress Default is already selected, I believe that's the one I'm running. I'm just using that header image rotator. Should I try and get everything (temporarily) as close to Default as I can?

  9. s1ade
    Member
    Posted 6 years ago #

    Any idea with this problem, it's still bugging me. I'm using ugly links on my sidebar so my pages at least work, but I it's not too great for SEO stuff and I like to have "?" excluded from my robots.txt

  10. Chris_K
    Member
    Posted 6 years ago #

    The two URL values under Options -> General are:
    http://photopics.ca/tom
    http://photopics.ca/tom

    Suppose you change those to http://www.photopics.ca/tom instead?

  11. s1ade
    Member
    Posted 6 years ago #

    Didn't work, same problem unfortunately

  12. Chris_K
    Member
    Posted 6 years ago #

    Dang. I thought sure that was going to be it. :-\

    What are the page slugs?
    Are there, by chance, folders or files with those same names in your WP directory?

  13. s1ade
    Member
    Posted 6 years ago #

    The page slugs are "contact-tom-slade" and "about-tom-slade" and there aren't any files even close to that in my directory.

    I tried making a new page just now called "wordpress-help" and same 404, http://www.photopics.ca/tom/wordpress-help/
    but it works at: http://photopics.ca/tom/?page_id=79

Topic Closed

This topic has been closed to new replies.

About this Topic