WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink pages not working (7 posts)

  1. thehutch
    Member
    Posted 5 years ago #

    Hello.

    I am moving from an old Movable Type blog to WordPress, so I'm a relatively newcomer to using WordPress. I'm sure this is a simple error that I can't figure out, but I wasn't able to find an answer by searching.

    Here is my blog: http://www.monitorduty.com

    I chose a permalink setting of http://www.monitorduty.com/2009/02/sample-post/ (i.e. "/%year%/%monthnum%/%postname%/").

    However, it does not seem to be generating pages for the archives or for the individual posts. If you click on the titles of the posts, or the categories, you will see what I mean.

    What am I doing wrong?

    Thank you in advance.

  2. Len
    Member
    Posted 5 years ago #

    Sounds like a problem with the htaccess file. What happens when you revert to the default setting?

  3. thehutch
    Member
    Posted 5 years ago #

    Thank you, LenK. You're right. If I put it back to default, it works.

    Shouldn't WordPress be rewriting the .htaccess file if I select one of the other options? I would rather use the year and month to classify my files.

    I read over the "Using Permalinks" help file. To be honest, I don't know what to make of it. I had a similar reaction looking at the .htacess file.

    Any suggestions or quick fixes?

  4. thehutch
    Member
    Posted 5 years ago #

    FYI: I was looking over the section called 'Using "Pretty" permalinks' and I'm checking to see if I have all of the requirements met.

    I have an .htaccess file and it's set to be writeable.
    I don't know if my host server is Apache. That could be the problem. I'm hosted by Powweb.com, so I'll go check their help resources.

    If I'm limited to the default, then c'est la vie.

  5. Len
    Member
    Posted 5 years ago #

    After having reverted to the default and your blog is working, try deleting the htaccess file. Switch again to "pretty permalinks" and let WordPress re-create the htaccess file and see what happens.

  6. thehutch
    Member
    Posted 5 years ago #

    That did it, man! Thank you very much, LenK.

  7. Len
    Member
    Posted 5 years ago #

    You're welcome. :)

Topic Closed

This topic has been closed to new replies.

About this Topic