WordPress.org

Ready to get started?Download WordPress

Forums

Permalink /&pagename& issues (4 posts)

  1. Tom Allen
    Member
    Posted 1 year ago #

    Hello all,

    Ive been trying to change my permalinks from the standard page number to the page name.

    I change the structure to http://www.mysite.com/%pagename%

    Upon doing this I restart the server, restart apache, and make sure the permalink structure has changed in the admin panel of each page.

    Then all of my pages crash, and it gives me this error:

    "Not Found

    The requested URL /clients was not found on this server.

    Apache/2.2.22 (Unix) PHP/5.3.15 with Suhosin-Patch mod_wsgi/3.3 Python/2.7.2 mod_ssl/2.2.22 OpenSSL/0.9.8r DAV/2 Server at http://www.mysite.com Port 80"

    I'm pretty sure it is something to do with the environment im hosting the site from, like some aspect of my server being out of date.

    Can anyone see something that im missing?

    Any help would be much appreciated.

  2. KleinBloemetje
    Member
    Posted 1 year ago #

    Hai,
    Changing the permalink structure on the admin panel of each page seems strange to me. I would use the "PermaLink" settings on the Settings page of the Admin panel.
    On that page, you could define the permalink structure to a personal setting, e.g. "/%postname%/".

    Maybe the issue is solved when you replace your reference to "pagename" with "postname"?
    Or maybe you are missing the closing "/"?

  3. Tom Allen
    Member
    Posted 1 year ago #

    Hi,

    Sorry I wasn't very clear in my explanation.

    First i change the "Permalink" settings in the settings page of the admin panel, and then check that each individual page has picked up on the changes.

    The closing "/" makes no difference.

  4. Danny de Haan
    Member
    Posted 1 year ago #

    Looks like your .htaccess isn't set well. Does it contain this?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.