WordPress.org

Ready to get started?Download WordPress

Forums

Permalink not working. Showing error 404 (5 posts)

  1. askoracledba
    Member
    Posted 6 years ago #

    Hi All,

    I am using wordpress 2.5.1 but permalink are not working. I was able to get the .htaccess content using "# AA RewriteRules" It is as below

    I wish to use permalink as http://askdba.org/weblog/2008/06/13/sample-post/ but its not working. Do suggest me what to do. Secondly I will not be able to edit .htaccess as my host provider (yahoo) does not provide shell access. So it will be great if you could provide any alternative.

    ========================
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /weblog/
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{HTTP_COOKIE} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/weblog/wp-content/cache/supercache/%{HTTP_HOST}/weblog/$1/index.html.gz -f
    RewriteRule ^(.*) /weblog/wp-content/cache/supercache/%{HTTP_HOST}/weblog/$1/index.html.gz [L]

    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{HTTP_COOKIE} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/weblog/wp-content/cache/supercache/%{HTTP_HOST}/weblog/$1/index.html -f
    RewriteRule ^(.*) /weblog/wp-content/cache/supercache/%{HTTP_HOST}/weblog/$1/index.html [L]
    </IfModule>
    =========================

    Thanks
    Amit

  2. NC@WP
    Member
    Posted 6 years ago #

    There is no alternative if you're hosting on Yahoo!. On Yahoo! servers, .htaccess files are forbidden and pretty permalinks will only work if you install (a Yahoo!-patched version of) WordPress via Yahoo! Web Hosting interface. Last I checked, they have not yet patched 2.5.1 to work on their servers, so if you install WordPress via Yahoo! Web Hosting interface, you'll get 2.3.something.

  3. askoracledba
    Member
    Posted 6 years ago #

    I installed that but it was quite a buggy one and was not allowing feeds :(
    I believe it was a bad option to choose yahoo ..

    Amit

  4. NC@WP
    Member
    Posted 6 years ago #

    I installed that but it was quite a buggy one and was not allowing feeds :(

    Of course it was. :) Only instead of a pretty URL:

    http://yoursite.com/feed/

    you needed to use an "ugly" one and specify what kind of feed you wanted:

    http://yoursite.com/?feed=rss
    http://yoursite.com/?feed=rss2
    http://yoursite.com/?feed=atom

    I believe it was a bad option to choose yahoo

    If pretty URLs are important, then you're certainly right...

  5. Justin Tadlock
    Member
    Posted 6 years ago #

    I've used Yahoo before, and they have crappy hosting.

    The best option is to go ahead and change hosts. This way you can avoid problems now and any future problems.

    Check out this page if you're interested in a better hosting solution:
    http://wordpress.org/hosting/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags