WordPress.org

Ready to get started?Download WordPress

Forums

Permalink not working (10 posts)

  1. daiver
    Member
    Posted 5 years ago #

    I just installed the new wordpress in my server and it is running fine except for permalinks.

    I checked the custom permalink structure field and just went with /%postname%/, however it 404s me every time.

    There is no .htaccess created in the dir and if I create one and assign 777 permissions to it, WP won't write to it.

    What's wrong and how can I solve it?

    Thanks!

  2. WebDev WaxLotus LLC
    Member
    Posted 5 years ago #

    Are you on a linux or windows server?

    Never set a .htaccess to anything higher than 660 and even then, for the shortest time possible...

    http://codex.wordpress.org/Using_Permalinks#Using_only_.25postname.25

  3. daiver
    Member
    Posted 5 years ago #

    Damn, I'm using lighttpd. =(

    Oh well, back to the old VPS with Apache...

  4. daiver
    Member
    Posted 5 years ago #

    I still have this problem and I would really like to fix it.

    I'm willing to pay someone to teach me how it is done so that I can do it for future installations.

    Please contact me: daiver - gmail - com

  5. BuckDaddy
    Member
    Posted 5 years ago #

    I am having similar problems

  6. med123
    Member
    Posted 5 years ago #

    Via an ftp program login to your server. In the root folder you should see a file named .htaccess

    It may be easier if you have cpanel installed: yourwebsite.com/cpanel

    If you do go to File manager and tick the box that says show hidden files (.htaccess should show up now).

    You can edit the .htaccess file from within File manager by clicking on the edit link near the top. Otherwise you can use notepad (but google htaccess and notepad - I think you have to upload it in a certain way). Once you have it open add the line(s) of code that wordpress suggested when you edited the permalinks setting.

    You'll realise how simple it is once you get through it the first time. I hope that helps!

  7. BuckDaddy
    Member
    Posted 5 years ago #

    I can find the htaccess but have no idea what code to put in there

  8. daiver
    Member
    Posted 5 years ago #

    The root of the problem is that I'm using Lighttpd.

    It is what comes with my VPS and changing it is a hassle.

  9. daveabrahams
    Member
    Posted 5 years ago #

  10. vikas.narayan
    Member
    Posted 5 years ago #

    Hi Guys . If nothing works try this .....
    you need to turn off magic_quotes_sybase
    For doing so open your .htaccess file
    and add php_flag magic_quotes_sybase Off

    Hope it works!!

Topic Closed

This topic has been closed to new replies.

About this Topic