WordPress.org

Ready to get started?Download WordPress

Forums

permalink not working (10 posts)

  1. gopaletal
    Member
    Posted 1 year ago #

    using window 7, wamp server installed in c:\wamp. created test database using phpmyadmin. created c:\wamp\www\test directory and copied wp 3.5 files and folders. installed wp for test with database as test, username as root, and password "". logged in to wp test dashboard. pw for test site at localhost works fine. wp opens test page and sample page. created new page as about us and about us page is working fine.

    problem starts when changed setting-> permalink to post name. then only test index page opens, and for all other pages, get error message "The requested URL /test/about-us/ was not found on this server." wp works fine when again permalink changed to default.

    tried many times, same problem.

    thanks in advance for your support.

  2. jamesg40
    Member
    Posted 1 year ago #

    when your working in your localhost, you need to set-up the php settings for mod rewrite. If you are running wamp, you need to click on the wamp server icon in the tray, choose the apache menu -> apache modules then move the menu down and select rewrite_module. You will have to restart the server for the changes to take affect. But it should get ya all fixed up there.

  3. Todd
    Member
    Posted 1 year ago #

    I am having the identical issue, but I haven't be able to resolve it yet. I've already tried jamesg40's suggestion to no avail. I also created a phpinfo.php page to verify the rewrite_module is active, which it is. I also tried editing the “httpd.conf” file by removing the comment hash from “LoadModule rewrite_module modules/mod_rewrite.so”. I have verified that when choosing the postname option for permalinks that WordPress is updating .htaccess file accordingly. Not sure what else to do. I'm running the latest version of WP and WAMP (2.2) on Win 7 x64.

    Suggestions?

    Any help would be appreciated !

  4. CNG SEO UK
    Member
    Posted 1 year ago #

    Ok these are my site files all the info is inside them to achieve what you wish.. Remember make copies of any originals.....

    I run a network multi site and run off localhost so please be observant of the differences..........

    http.conf

    [ Code moderated, please use pastebin.com instead. ]

  5. CNG SEO UK Please start your own topic. It's considered impolite to try and take over someone else's topic with your problem.

    http://wordpress.org/support/forum/localhost-installs#postform

    Also don't post that many lines here. Use pastebin.com instead.

  6. howarddrive
    Member
    Posted 1 year ago #

    for trying permalink just goto setting -> permalink & set ur parmalink to page name.

  7. smdegreeusa
    Member
    Posted 1 year ago #

    thanx @ howarddrive I got the solution only because of you thanx a lot....... :)

    I think wordpress is much more better than joomla and drupal and its easy to use toooo

  8. Cyber735
    Member
    Posted 1 year ago #

    Hi,

    I've got the exact same problem, however I'm using Instant WordPress.

    It's not that big of an issue, as I'm sure it will resolve itself when I publish the site on the web, right?

    Thanks,

  9. equerambug
    Member
    Posted 11 months ago #

    Thanks @farsabbutt

    your link work for me..

  10. inspiredwp2013
    Member
    Posted 7 months ago #

    a simple solution to do this is go to WAMP and enable the rewrite_module.

    1. click on the WAMP icon in your task bar
    2. Apache
    3. Apache modules
    4. Scroll down to rewrite_module and enable it.

    now go to your permalinks and add this /%postname%/
    that should work. hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic