WordPress.org

Ready to get started?Download WordPress

Forums

Permalink issues in 2.7.1: Only default and Numeric settings work (20 posts)

  1. gilzow
    Member
    Posted 5 years ago #

    Server is RHEL5, running PHP 5.1.6

    I need to set up a custom permalink structure (specifically: /%year%/%monthnum%%day%-%postname%/) but only the default setting (/?p=%post_id%) and numeric (/archives/%post_id%) work. All other structure (Day and Name, Month and Name, or my custom) end up going to the post not found message.

    The .htaccess file is in place and is working correctly. If I try to navigate directly to http://site.com/?p=118, wordpress redirects to http://site.com/2009/0529-my-post-title/. If I insert phpinfo();exit(); into the index.php page that requests should be redirecting to, and then navigate to http://site.com/2009/0529-my-post-title/ i get the phpinfo as I should.

    Any ideas? Something easy I'm overlooking? I dont mind digging into canonical.php but would rather not if i dont have to.

  2. jimmytubbs
    Member
    Posted 5 years ago #

    Where is your .htaccess file located?

  3. gilzow
    Member
    Posted 5 years ago #

    Where is your .htaccess file located?

    root of the wordpress installation.

  4. gilzow
    Member
    Posted 5 years ago #

    anyone have any guesses/ideas?

  5. HollyJahangiri
    Member
    Posted 5 years ago #

    Ahah!! It's not just me!!! Thank you, thank you, thank you - I was starting to feel really stupid, certain this had to be "inexperienced user error." I'm getting the same thing!

    No suggestions or guesses - but if you find an answer, I'd like to see it, too!

  6. Samuel B
    moderator
    Posted 5 years ago #

    @ HollyJahangiri
    it's not the same problem at all as in your topic

    @ gilzow
    the structure you have posted won't work
    you need it like
    /%year%/%monthnum%/%day%/%postname%

    http://codex.wordpress.org/Using_Permalinks#Choosing_your_permalink_structure

  7. gilzow
    Member
    Posted 5 years ago #

    @samboll - except that it still doesnt work. Neither my custom permalink structure, the permalink structure you posted, nor any of the default permalink options (Day and Name or Month and Name) work. So even if I set it up the way you suggested (/%year%/%monthnum%/%day%/%postname%) I still get the 404 post not found message. Only the default and numeric permalink structures work correctly.

  8. HollyJahangiri
    Member
    Posted 5 years ago #

    See, I think it IS the same problem, Samboll.

    Your suggested "fix" is what I'd already tried. I've implemented it again so that you can see what it IS doing, but it's not right.

    Unlike glizow, I don't think anything but the Default structure works for me.

  9. HollyJahangiri
    Member
    Posted 5 years ago #

    http://jahangiri.us/news/ <-- Looks fine. But click the titles - the permalinks look lovely, now, but they don't WORK:

    http://jahangiri.us/news/2009/05/president/
    http://jahangiri.us/news/2009/05/the-da-vinci-cruise/

  10. Ryan S
    Member
    Posted 5 years ago #

    I am not sure what wrong you are doing, but the correct permalink will be /%year%/%monthnum%/%day%/%postname%

    Also, check if you have any unnecessary plugin installed.

  11. gilzow
    Member
    Posted 5 years ago #

    @ryan_accuwebhosting no offense, but your "help" isn't very helpful. Telling me that I'm doing something wrong, and then suggesting that I try something that I have already stated twice that I *HAVE* tried is a bit frustrating.

    Now your suggestion on plugins might have some validity. @HollyJahangiri, do you mind listing the plugins you have installed? Let's see if we are both using one or more and then look into whether or not those plugins might be causing an issue.

    Co-Authors
    Dr. Register
    More Fields
    Subscribe2
    WordPress Admin and Login Themer
    wpDirAuth
    WP Hide Dashboard

  12. gilzow
    Member
    Posted 5 years ago #

    ok, so i went back and uninstalled all of the plugins I was using, changed the permalink settings to default, saved, changed them back to Day and name, saved again and tried to go to my test post (http://uablogs-dev.missouri.edu/2009/06/03/this-is-a-test-post/ <-- you wont be able to get there; only posting so you can see URL structure is correct) and received the 404 error message. I also went in and added a category base and a tag base as another forum thread mentioned that adding those had helped another user's permalinks start working correctly. I still get the 404 error.

    So then I went and redownloaded the wordpress core and installed it into another account that I have so that it would be perfectly clean and no possibility of something interfering. After logging in I changed the permalink setting to Day and Name, saved, verified the .htaccess file was created, created a test post, published and attempted to go to the generated pretty URL, i get a 404 error. Only default and numeric permalink settings work.

    I have also verified with our SysAdmin that the FollowSymLinks options is enabled for my account.

  13. HollyJahangiri
    Member
    Posted 5 years ago #

    For me, it turned out to be a simple permissions problem. (Compounded by the fact that I'd put .htaccess under wp-content to start with.) I ended up opening my entire installation with 777, getting WordPress to finally generate the .htaccess file (that put it in the right place, at least), and everything worked - until Apache shut me out. 403 error. I thought my hosting support folks did it, just to stop me from mucking around while they tried to troubleshoot. But for some reason, some things won't work with the documented permissions - they won't work unless set to 777. Not 666. Dunno why, but for most things, it may be easier to edit offline - not use the built-in editor. Then again, without the built-in editor, I might never have figured out where .htaccess really ought to be. :)

  14. HollyJahangiri
    Member
    Posted 5 years ago #

    Plug-ins activated (this has changed, most likely, since the problem was fixed - but I think it's irrelevant):

    Akismet 2.2.4
    All in One SEO Pack 1.5.1
    commentluv 2.6.5
    Feed reading Blogroll 1.2.1
    Import Blogroll With Categories 1.0
    OpenID 3.2.2
    Sociable

  15. Ryan S
    Member
    Posted 5 years ago #

    gilzow

    Yes, I understand that you have already stated the permalink structure and it was correct. However, I provided you the structure just to make sure if you are using it correctly.

    Also, try to check the permissions again... One more thing.. make sure the the reqrite rule is present in your .htaccess file (I know it sounds stupid, but sometimes this happens).

  16. tikdi
    Member
    Posted 5 years ago #

    If nothing works then maybe it is the problem that I faced.
    - Upgraded to WordPress v 2.8.1 - no problems before that
    - Tried to change permalinks and got all these unsolvable htaccess errors
    - Even deleted the WP installation and everything and reinstalled but same problem
    - Got a brainwave - Thank God!
    - Went to WP Settings -> General, changed the default settings for BOTH URL areas to point to simply http://www.mydomain.com
    - Permalinks working again !
    - Actually I am using the 'add domain' feature to host multiple domains in a single account in bluehost. So the default in WP settings points to http://www.basedomain.com/mydomain which dosen't work.

    - Trust that helps someone.

  17. Joona Nuutinen
    Member
    Posted 4 years ago #

    tikdi,
    thank you so much, your instructions fixed my problem too.

  18. stephenn
    Member
    Posted 4 years ago #

    Been having similar probs....
    htaccess worked but 404 page not found appeared...

    tried looods of stuff as above...

    ANSWER (for me):
    in the permalinks custom setting I had this:
    /index.php/%category%/%postname%/%post_id%/
    i removed the /index.php/ and just left it as this:
    /%category%/%postname%/%post_id%/

    Just thought would mention if may add an ''option to try''
    cheers

  19. knia
    Member
    Posted 4 years ago #

    hi
    im having problems with my permalinks. I edited and made a custom one and now i cant go back to edit again back to the default permalink. Cant understand why i cant??
    Ever since customizing the permalink the page titles such as "about" "contact" have gone missing (the pages are still there) except when on the "home page".
    can someone help please!
    its really urgent

  20. Lynque2me
    Member
    Posted 4 years ago #

    Look for this line in your httpd.conf file under Apache in a WAMP set up

    #LoadModule rewrite_module modules/mod_rewrite.so

    Uncomment that (Remove # sign) this will allow for mod_rewrite rules to work.

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Topic