WordPress.org

Ready to get started?Download WordPress

Forums

Permalink Issues (3 posts)

  1. stephenr85
    Member
    Posted 6 years ago #

    Adding a category and tag base seemed to help one of my posts, but another post is still showing the friendly WordPress "Not Found" page.

    http://blog.stephenrushing.com/
    http://blog.stephenrushing.com/index.php/2008/08/6/

    The main difference between the two posts is that there are multiple categories on the one not displaying properly.

    Any idea why the URL just says "6", instead of being a little closer to the post name?

    Also, why does this URL show correctly, even with index.php in it?
    http://blog.stephenrushing.com/index.php/category/wordpress/

  2. stephenr85
    Member
    Posted 6 years ago #

    Ok, apparently the index.php needs to be there. I missunderstood the provided post about the permalinks issue.

    Both article links are working now with the following permalink settings:

    Custom Structure: /index.php/%category%/%postname%/

    Category Base: /category

    Tag Base: /tag

    That still leaves the question about the URL on this'n.
    http://blog.stephenrushing.com/index.php/wordpress/6/

  3. kgagne
    Member
    Posted 6 years ago #

    If you're wondering where "6" came from, it's the post ID.

    I don't think index.php should have to be there, unless you want it to be. I'm unsure what structure you are trying to create. My "category base" and "tag base" fields are blank, as I believe they default to what you're using anyway.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags