Ready to get started?Download WordPress


Permalink Issue ( .htaccess is correct and mod rewrite enabled) (2 posts)

  1. chirax
    Posted 3 years ago #

    WP Forum,

    I am posting this after a two day research on google and countless hacks.

    Problem: Permalink Links(Pretty Permalinks) not working on my wp install after I upgraded from 2.8 to 3. This is not working with any theme. If enabled permalinked(http://iamstarting.com/2010/10/sample-post/) page are all going to error page.

    What I have done so far.

    • .htaccess is in the root folder
    • I am using /%year%/%monthnum%/%day%/%postname%/ in the dashboard>Setting>Permalink Settings
    • Custom Structure is checked
    • Confirmed with my web hosting provides Mod rewrite is enabled

    Please guide is how can I resolve this.


  2. Tara
    Posted 3 years ago #

    have you tried:

    -Double check your wp-config.php file settings for the database and host names.
    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems.

    - resetting the plugins folder by FTP or phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

Topic Closed

This topic has been closed to new replies.

About this Topic