WordPress.org

Ready to get started?Download WordPress

Forums

Permalink Issue - Everything but default (5 posts)

  1. BtazBt
    Member
    Posted 1 year ago #

    I've had a series of server, router, and internet issues lately so I'm not sure if I'm starting in the right area. Prior to all my issues, I'm quite certain that my website was working just fine with 3.4.2 using "numeric" permalinks. Now that I'm back up and working it seems that I get the "404 page not found" for all my pages except my homepage. After reading some other forum posts here and there they suggested changing the Permalink setting. So I played around with this some and when I have the option set to "default" everything seems to work fine, but if I try any of the other options it doesn't work. Any ideas?

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Check with your hosts that mod_rewrite is running on your server.

  3. BtazBt
    Member
    Posted 1 year ago #

    I'm the host for my website too and can confirm that mod_rewrite is enabled in my Apache config.

    LoadModule rewrite_module modules/mod_rewrite.so

    One new thought, though I'm not too sure how to test this, is that in resolving my server issues I upgraded to Apache 2.4.3, PHP 5.4.3, and MySQL 5.5. Of particular importance in Apache 2.4.3 'Order' commands are depreciated. This caused me to have to go change all of my re-write rules.

    Does anyone know if WordPress 3.4.2 is compatible with my server application versions? I don't see any documentation in the Support->Docs section about this (The only mention is that mod_rewrite has to be enabled, as esmi noted above).

    Where do wordpresses re-write rules exist? I'm wondering if I can look at them and do some testing with the rules to see if this is the issue.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Where do wordpresses re-write rules exist?

    In the generated .htaccess file.

  5. BtazBt
    Member
    Posted 1 year ago #

    Well I see one issue with the rewrites, but my fix doesn't solve the problem

    default Permalinks
    URL

    http://mysite.com/wordpress/?p=435

    .htaccess file

    # BEGIN WordPress

    # END WordPress

    numeric Permalinks (and other options
    URLS:

    http://mysite.com/wordpress/archives/435

    .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    per the Apache 2.4.3 documentation "To enable the rewrite engine in this context, you need to set "RewriteEngine On" and "Options FollowSymLinks" must be enabled."

    Adding 'Options FollowSymLinks' after the RewriteEngine line doesn't solve the problem, but it should be added.

    So it looks like I'll have to dig into index.php and all the files it moves to to understand where the disconnect is.

    Any good ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic