WordPress.org

Ready to get started?Download WordPress

Forums

Permalink issue due to move - help request (9 posts)

  1. mrkingid
    Member
    Posted 6 years ago #

    In need of some assistance.

    I developed a site for a buddy and created under my domain first. My site is on godaddy, FWIW.

    eg: http://artbymichaelking.com/bikram (site not there anymore)

    Everything was created and functional. I had permalinks structure as /%postname%/ and it all worked smoothly.

    I moved the blog to http://bikramhotyoga.ca/ (hosted on Easyhost)given the instructions in the WP CODEX. Everything transfered fine and the site is working using default permalink structure (http://bikramhotyoga.ca/?p=123)

    When I change the permalink to http://bikramhotyoga.ca/%postname%/ and hit update, it tells me it is successfull, BUT when I try to navigate the site I get a 404 Forbidden access message.

    Note that it was created in a sub directory /bikram/ but when moved it was placed in the root directory.

    I am hoping one of you experts can help me out.

    All I want to do is have the permalinks set at http://bikramhotyoga.ca/%postname%/ so I can better track the page hits in google analytics.

    My index.php is:
    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

    .htaccess is in the root directory and reads:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  2. mrkingid
    Member
    Posted 6 years ago #

    Any guru have any suggestions?

  3. moshu
    Member
    Posted 6 years ago #

    THere is something wrong with that whole setup of yours:
    http://bikramhotyoga.ca/
    it gives me a 403 forbidden. Check your permissions

  4. mrkingid
    Member
    Posted 6 years ago #

    yeah I was screwing with the permalinks and that is the error it give me.

    Try it now as I reverted the permalinks to default

    I have learned that the servers on Easyhost run linux and Frontpage. Looking into that now as well.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    You should still be using /%postname%/ for your permalink settings, like before. Don't put the http stuff into it.

  6. mrkingid
    Member
    Posted 6 years ago #

    yes, I have just used the /%postname%/ but to no avail either.

    Frontpage is not activated on my domain so that is not it.

    I am starting to bang my head against the wall.

    maybe if others can look at my info.php file it will help...

    http://bikramhotyoga.ca/info.php

  7. Chris_K
    Member
    Posted 6 years ago #

    In glancing at that info page, I don't see mention of mod_rewrite -- your host needs that for the pretty permalinks (see Permalinks for more info).

    You could use "almost pretty" permalinks -- try putting index.php/%postname%/ in the custom field.

  8. mrkingid
    Member
    Posted 6 years ago #

    hmm, my blog with pretty permalinks working says nothing about mod_rewrite either.

    Is there a way to check if mod_rewrite is on without having access to Apache?...

    no worries, just found one

    http://www.wallpaperama.com/forums/how-to-test-check-if-mod-rewrite-is-enabled-t40.html

    Looks like mod_rewrite is not on.

  9. mrkingid
    Member
    Posted 6 years ago #

    ok mod.rewrite is on now, but i still can't get the second permalink selection to work.

    sample only; link doesn't work ยป http://bikramhotyoga.ca/2007/12/27/sample-post/

    grrrr...

    Would it have to do with migrating the installation over?

    Would having this issue have anything to do with having my memory_limit locked at 8M?

Topic Closed

This topic has been closed to new replies.

About this Topic