WordPress.org

Ready to get started?Download WordPress

Forums

Permalink Issue - Can't Remove /index.php/ without 404 errors (1 post)

  1. Morkouz
    Member
    Posted 1 year ago #

    Hi, I'm quite new to wordpress, i've recently updated to 3.4.2 (manually) and can't seem to get my permalinks working again (http://www.markseabridge.com). Its a pretty simple site and i just want the top nav items to direct to the relevant page (ie http://www.markseabridge.com/about/) but can only now get the default settings to work (http://www.markseabridge.com/?p=123) or the post name with index.php/in the extensions (http://www.markseabridge.com/index.php/sample-post/).

    Although I backed everything up via my FTP (and database from PHPMyAdmin) I foolishly didn't have show hidden files selected so my .htaccess file wasn't backed up.

    I've created a new .htaccess file following what I've read on the forums (code pasted below). When i update to the same custom structure that previously worked (simply /%postname%/) I get no error message just "Permalink structure updated." However it hasn't updated, instead i get 404 errors.

    Can anyone help shed any light? I've tried deactivating all the plugins, switched to the twentyeleven theme and still the same errors.

    Thanks in advance from a frustrated designer trying to get to grips with WP.

    <---- code for my .htaccess file ---->

    "# BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress"

Topic Closed

This topic has been closed to new replies.

About this Topic