WordPress.org

Ready to get started?Download WordPress

Forums

Permalink Issue (2 posts)

  1. charlesferrer
    Member
    Posted 1 year ago #

    Hi all,
    I know this post might be similar to the ones that have been posted before but I have been looking around to see if anyone had the same issue as myself with no luck.
    I've been having problems with an error code "404 Not Found" followed by a message "The requested URL /xva0wordpress/index.php was not found on this server.
    "Its seems that when I change my permalinks to anything else but default, it will come up with the error.I dont really want the permalinks to be on default as this is part of my examination to make the site SEO friendly. All this work is not online at the moment as im working on my localhost using "MAMP".If someone could tell me how I could sort this out that would be great.

    Thanks in advance
    Charles

  2. AyoubEzzo
    Member
    Posted 1 year ago #

    Hi charlesferrer

    check first if .htaccess file is working, it should be as below:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /Reptontest/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /Reptontest/index.php [L]
    </IfModule>

    # END WordPress

    The step that solved my problem was:

    Check the apache\conf\httpd.conf file for the line `# LoadModule rewrite_module modules/mod_rewrite.so and delete the # in front of the line. Then stop Apache and start it again

Topic Closed

This topic has been closed to new replies.

About this Topic