WordPress.org

Ready to get started?Download WordPress

Forums

Permalink issue (4 posts)

  1. murej
    Member
    Posted 2 years ago #

    Hey,

    Editing permalink settings seem to work normally according to wordpress, however in WP root folder .htaccess is not being created nor edited if I create and chmod it to 666.

    If I edit my settings to /index.php/blog/%postname% everything seem to work ok, but if I want it to be /blog/%postname% I get a server 404 msg for everything except home page (not even using 404 template, which is used normally otherwise).

    In any case I get a message saying "Permalink structure updated.", which should mean .htaccess is editable.

    I'm losing my mind here, any help would be greatly appreciated.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    That sounds as if it's server related. Are you using a *nix or Windows server? Have you spoken to your hosts about this?

  3. murej
    Member
    Posted 2 years ago #

    It should be running on Linux (not 100% since it's a private server). I told them to enable mod_rewrite, but WP has been behaving the same before and after that.

    Any ideas what more I could tell them?

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    It does sounds as if mod-rewrite isn't working properly. Either that or the server isn't parsing the .htaccess file correctly. The issue with the .htaccess file not being updated is another concern. all in all, not a server I'd be too comfortable using. Is this a split php/asp server by any chance?

Topic Closed

This topic has been closed to new replies.

About this Topic