WordPress.org

Ready to get started?Download WordPress

Forums

Permalink / htaccess RC3 (28 posts)

  1. Mazalien
    Member
    Posted 8 years ago #

    Hello everybody. I have upgraded to RC3-2.0 from 1.5.2. Before upgrade I made backups from .htaccess and the database. The problem is the following: When updating the permalink structure Wp remove all the rewrite rules I had before in 1.5.2. and leaves almost a blank file :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>
    # END WordPress

    So all my rewrite rules as I had them in 1.5.2. are dissapeared and I cannot acces all my pages and sub-pages because of redirection to the index-page.
    Putting the old htaccess file back works but this isn't the solution. I used the following permalinkstructure :
    archives/%year%/%monthnum%/%day%/%postname%/.
    Is this a RC3 problem / Or a bug? Or will it be solved in the difinite version
    Anybody?
    Greetings Mazalien

  2. Can you set your permalink structure again in Options/Permalinks?

  3. Mazalien
    Member
    Posted 8 years ago #

    Macmanx, I have tried that for dozens of times and every time the same problem. I have also set up an another wp-installation of rc3 in a different database, a complete new installation with some dummy-posts and categories, and there is the problem the same. When putting 1.5.2. back in the "dummy" database then the permalinks works just fine.

  4. Do you use a backslash before "archives" in your permalink structure? The structure needs to start with a backslash:

    /archives/%year%/%monthnum%/%day%/%postname%/

    If that still doesn't work, try the recommended permalink structure:

    /%year%/%monthnum%/%day%/%postname%/

  5. Mazalien
    Member
    Posted 8 years ago #

    Yes I have used the backslash, and also tried every other possible combination. The only thing that change is the size of the .htaccess file with a few bytes every time (from 204 bytes to 208 bytes) and some empty lines are added under the # end wordpress-statement. I have also chmod .htaccess to 777, so it is writable.

  6. What are your server details? Preferably your server's operating system and Apache, PHP, and MySQL version numbers.

  7. Mazalien
    Member
    Posted 8 years ago #

    PHP: PHP4u Version 3.0
    Based on PHP-5.0.2
    MySQL 4.0.18
    Server statistics :

    Initiating SYN Stealth Scan against customers.webc.lyceu.net (212.78.206.150) [1668 ports] at 21:05
    Discovered open port 80/tcp on 212.78.206.150
    The SYN Stealth Scan took 29.40s to scan 1668 total ports.
    Warning: OS detection will be MUCH less reliable because we did not find at least 1 open and 1 closed TCP port
    For OSScan assuming port 80 is open, 32587 is closed, and neither are firewalled
    Host customers.webc.lyceu.net (212.78.206.150) appears to be up ... good.
    Interesting ports on customers.webc.lyceu.net (212.78.206.150):
    (The 1667 ports scanned but not shown below are in state: filtered)
    PORT STATE SERVICE
    80/tcp open http
    Device type: general purpose
    Running: Linux 2.4.X
    OS details: Linux 2.4.16 - 2.4.18, Linux 2.4.18 - 2.4.21 (x86)
    OS Fingerprint:
    TSeq(Class=RI%gcd=1%SI=1CB3A5%IPID=Z%TS=100HZ)
    T1(Resp=Y%DF=Y%W=16A0%ACK=S++%Flags=AS%Ops=MNNTNW)
    T2(Resp=Y%DF=Y%W=0%ACK=S%Flags=AR%Ops=)
    T3(Resp=Y%DF=Y%W=16A0%ACK=S++%Flags=AS%Ops=MNNTNW)
    T4(Resp=Y%DF=Y%W=0%ACK=O%Flags=R%Ops=)
    T5(Resp=N)
    T6(Resp=Y%DF=Y%W=0%ACK=O%Flags=R%Ops=)
    T7(Resp=N)
    PU(Resp=N)

    Uptime 47.908 days (since Thu Oct 20 23:19:05 2005)
    TCP Sequence Prediction: Class=random positive increments
    Difficulty=1880997 (Good luck!)
    TCP ISN Seq. Numbers: 102EAC5C 101037FC 1002E86F FEB7AAC 10398C09 108B3910
    IPID Sequence Generation: All zeros

    Nmap finished: 1 IP address (1 host up) scanned in 32.039 seconds
    Raw packets sent: 3359 (135KB) | Rcvd: 18 (940B)

  8. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    The rewrite rules that redirect to the index are the default for 2.0. They should work. To help debug this problem, install and activate the Dump Environment plugin. Visit a page that is not working properly and save the page source. Send that page source to ryan at boren dot nu. Deactivate the plugin when you're finished.

  9. Mazalien
    Member
    Posted 8 years ago #

    Ryan thanks. I will give it a go...

  10. Mazalien
    Member
    Posted 8 years ago #

    Ryan I have sent you an email today. Let me know If this is what you meant.
    Greetings

  11. kickass
    Member
    Posted 8 years ago #

    I just had a problem with permalinks in a new install of 2.0. I had chmodded the .htaccess and let WP update that-- and the permalinks didn't work. Tried a couple things, like getting rid of the category, which I know was problematical in the past, but that didn't work. So I restricted the chmod on .htaccess, did the permalink thing again, then MANUALLY edited the .htaccess file, being careful to make sure there wasn't any trailing whitespace -- and the problem was fixed.

  12. davidhouse
    Member
    Posted 8 years ago #

    When you say you edited it manually, how exactly? What did you change?

  13. kickass
    Member
    Posted 8 years ago #

    Well, if the file isn't writable it will give you the text you need to put into the .htaccess file.

    That's what fixed it for me.

    Unfortunately it's broken again and all that was done was a few things were done in admin. Has ANYONE gotten Permalinks working PERMANENTLY in 2.0?

  14. incrediblehelp
    Member
    Posted 8 years ago #

    I got the same issues here in 2.0

  15. WPChina
    Member
    Posted 8 years ago #

    I have the exact same problem. I DID fix it, though, by adding "index.php" to the permalinks so that it looks like this:

    /index.php/%year%/%monthnum%/%day%/%postname%/

    I have been working on this problem now for about 8 hours. very frustrating.

    The above URL works, but I would much much rather not have "index.php" in the URL... I hope there is a fix...

    Any advice?

  16. Samuel B
    moderator
    Posted 8 years ago #

    I am running WP 2.0.1
    My permalink structure is:
    /archives/%post_id%

    I have also tried:
    /%year%/%monthnum%/%day%/%postname%/

    Everything works fine.

  17. WPChina
    Member
    Posted 8 years ago #

    I am running WP2.0.1 too and it is working fine for me on one installation, but not on another. The problem confounds me. :-(

  18. 3stripe
    Member
    Posted 8 years ago #

    I'm having same problems with WP 2.0.1

    Permalinks seems to work if I include index.php at the start - I don't want this in every url though!

    The control panel is only telling me it can't write to .htaccess 10% of the time, and the rest it's not even adding anything to it!!?

  19. strangnet
    Member
    Posted 8 years ago #

    Does the .htaccess-file contain the required items, then?

  20. 3stripe
    Member
    Posted 8 years ago #

    No it's completely empty either way, even when it says it's been updated. I've just deleted it completely and made a new .htacess file but still it's empty...

    The control panel is telling me: "Permalink structure updated" but .htaccess is still empty, so of course am getting 404 errors when i try to view a post.

    Hmm.

  21. 3stripe
    Member
    Posted 8 years ago #

    Is this a bug or am I just stupid !?!?

  22. 3stripe
    Member
    Posted 8 years ago #

    Or maybe both :-P

  23. 3stripe
    Member
    Posted 8 years ago #

    Still stuck with index.php in front of all my permalinks for them to work... is there a way to fix this?

    Cheers :-D

    James

  24. richard22
    Member
    Posted 8 years ago #

    I'm not sure if this has anything to do with this thread but I am running 2.0.1 and I am trying permalink structure
    /%postname%/%monthnum%/%year%/ and I get a warning notice "you should update your htaccess now"
    Is this correct and being a newbie I am not sure how to do that?

    Richard

  25. J3r0m3
    Member
    Posted 8 years ago #

    i'm also having this problem.
    i created a fresh htaccess and uploaded it.

    i set the options->permalink to /index.php/%year%/%monthnum%/%day%/%postname%/
    and it tells me that the structure updated.

    i take a look at the htacess and its still empty.

  26. asterox
    Member
    Posted 8 years ago #

    my permalink issue is also fixed by adding /index.php but i'd rather not do that as well. anyone else have thoughts on this?

  27. intricateartist
    Member
    Posted 8 years ago #

    I'm having the same issues, and waiting for responses on 2 other open threads. Anyone have any answers yet? If anyone knows how to fix this, please e-mail me - I'd appreciate the assistance.

    (Here's another thread with more people having the same issues)

  28. v8media
    Member
    Posted 8 years ago #

    I don't know if this will be helpful or not, but here's what worked for me. (fingers crossed that it will stay that way)

    I was having problems with the htaccess file not being created, so I was editing the file myself with variations on what wordpress was offering. Nothing would work, but it was obviously an access issue. Take out the htaccess file and I could type in some links and get places, but no links would work within the site.

    I finally changed the permissions to the htaccess file to 777 instead of the 666 that was recommended and . . . that was all it took! Changed it back to 664 and it's still working. This was causing me pain yesterday and I just lucked into it. So try 777 for permissions if you're having a similar issue.

    Good luck, Ian

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags