WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink "fix" does not work for pages (3 posts)

  1. gregdrums
    Member
    Posted 6 years ago #

    I tried the fix of putting the words "category" and "tags" into the proper boxes under setttings>permalinks. Still, my pages are 404.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    What is your custom permalink setting?

    Also, add this to your theme's footer.php:

    <!--
    <?php
    var_dump($wp_rewrite->wp_rewrite_rules());
    ?>
    -->

    Then go to your webpage and reload it, view the source, and copy/paste the new stuff at the bottom of the page into here so we can see what your rewrites look like.

    Delete the code from the footer.php afterwards, you don't want to leave it there.

  3. gregdrums
    Member
    Posted 6 years ago #

    Thank you for your help, but now it is working. Perhaps it just needed 30 mins. to sort itself out? Not sure, since I refreshed all pages, tried logging out, etc. and was getting nowhere. Now at least the original suggestion works.
    Otto, I think your sticky note on this subject should have "under settings>permalinks" as the suggestion not "under settings>miscellaneous" Just an FYI. Thanks for your continued work on this.
    -Greg

Topic Closed

This topic has been closed to new replies.

About this Topic