WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink creates conflicting URL's (6 posts)

  1. Cocles
    Member
    Posted 5 years ago #

    My site's most popular post is "Future Expansions for WoW".
    Its URL is "http://www.loregy.com/world-of-warcraft/future-expansions/"

    Here's where it gets wonky.

    When I try to create a post titled "Future Expansions: Maelstrom or Emerald Dream?" and place it in the "World of Warcraft" category, WordPress tries to give it the url "http://www.loregy.com/world-of-warcraft/future-expansions/" even though that URL is already taken.

    What happens then is even weirder. Should you actually go to "http://www.loregy.com/world-of-warcraft/future-expansions/" you will see the DRAFT copy of "Future Expansions: Maelstrom or Emerald Dream?" even though it's not published yet.

    The only way to consistently fix this problem is to completely delete "Future Expansions: Maelstrom or Emerald Dream?" Once that is done, everything goes back to normal.

    Any thoughts on this? I'd really like to be able to put "Future Expansions" at the head of multiple posts without WordPress going all wonky.

    Note: If I save my new Future Expansions article (creating the conflict) then go and re-save my old Future Expansions article it'll tack a "2" on the end of the OLD post. If only I could get it to stick that "2" on the end of the NEW post instead.

    Second Note: Is Joost's Permalink Redirect deprecated? Whether I have it activated or not makes no difference. Either way there is a still a "Permalinks" option under "Settings".

  2. Cocles
    Member
    Posted 5 years ago #

    *Bump* Anyone have any ideas? Would posting my .htaccess file help?

  3. geniosity
    Member
    Posted 5 years ago #

    Just out of curiosity, what happens if you remove the colon from the title? (You'll have to create a new post to try this out, because now the URL for this post has already been set).

  4. Thatedeguy
    Member
    Posted 5 years ago #

    It sounds like you've got a plugin of some sort that is shortening the URL, or something in your permalinks that keeps it from being longer. If that's the case, you end up with a shortened url much like another that you wrote earlier.

    For a quick fix, you might try using the same title, and then editing the permalink below it to reflect something difference.

  5. Cocles
    Member
    Posted 5 years ago #

    Removing the colon had no effect, but thank you for the suggestion.

    I found something else out too. If I save the post in the "uncategorized" category instead of the "world of warcraft" category, it generates this URL: http://www.loregy.com/uncategorized/expansions-maelstrom-or-emerald-dreamfuture/

    But if I then change the post to the "world of warcraft" directory and resave it, it changes the permalink to the one that conflicts with the earlier post: http://www.loregy.com/world-of-warcraft/future-expansions/

  6. Cocles
    Member
    Posted 5 years ago #

    Solved! Thatedeguy was correct; the problem was caused by the plugin "Slug Trimmer". Deactivating the plugin of course fixed the problem, but simply turning off "truncating" within the plugin's settings also appeared to fix everything.

Topic Closed

This topic has been closed to new replies.

About this Topic