WordPress.org

Ready to get started?Download WordPress

Forums

Permalink cluster*#$@ (23 posts)

  1. urbanscout
    Member
    Posted 6 years ago #

    I wanted to change my permalinks to be just the postname. Every time I change it to that, none of my links work. I created an .htaccess file with the code wordpress told me:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I created an .htaccess file and tried putting it both in urbanscout.org/.htaccess and urbanscout.org/wordpress/.htaccess.

    I changed the permissions of the .htaccess to be able to 666 as they said.

    When I have the file in urbanscout.org/.htaccess my site does not work. Even when I have a blank file called .htaccess in this folder, the site says, "Server error."

    When I have the file in urbanscout.org/wordpress/.htaccess, the main page loads, but when I click on a blog to read it, I get a 404 not found page.

    I thought it might be because I changed it to only the postname and it said you may have trouble doing that, but I changed it to several other options and none of them worked. I don't understand why my wordpress options told me that it could not access my .htaccess file even after I changed the permissions.

    According to my host GoDaddy, I have Apache, so the mod_rewrite should work:
    http://help.godaddy.com/article.php?article_id=898&topic_id=

    I read through the wordpress site:
    http://codex.wordpress.org/Using_Permalinks

    As suggested in the permalinks page here, and a few other places, I tried changing my wp-includes/vars.php file to:

    $is_apache = 1;

    and my site would not load, saying that there was an error on file wp-includes/vars.php line 37.

    AAAAHHH! Please help me.

  2. Chris_K
    Member
    Posted 6 years ago #

    I don't have any great ideas, but isn't GoDaddy the host that folks have to wait 30 or 60 minutes for .htaccess file changes to go into affect?

    Worth a quick search here in the forums to see if I'm thinking of the right host?

  3. urbanscout
    Member
    Posted 6 years ago #

    Yeah I saw that here:
    http://wordpress.org/support/topic/142676?replies=3

    But, even when I do upload an .htaccess file, the site stops working right away. Do you think this is connected? Do you think I need to upload it and wait to see what happens? I mean, it must register something if the site stops working.

  4. urbanscout
    Member
    Posted 6 years ago #

    I found a little more info here:
    http://gidden.net/tom/2006/05/26/4/

    But I'm still confused.

  5. urbanscout
    Member
    Posted 6 years ago #

    I found another site that says you have to wait like an hour. So I have now uploaded a new .htaccess file to urbanscout.org/.htaccess. with the wordpress mod_rewrite code. I Changed the permissions to 666.

    Before I was having problems with the site loading at all. It seems to load the main page now. But the links still don't work. I'll wait an hour or so and see what happens. I've also got a call into Godaddy support to clarify with them.

  6. urbanscout
    Member
    Posted 6 years ago #

    Okay, so I waited about an hour, checking frequently if the site would work. Now all of a sudden the main page of the site is not working. At this point I think I'll just wait a little longer and see if anything else happens.

  7. urbanscout
    Member
    Posted 6 years ago #

    Here is what godaddy had to say:

    Thank you for contacting Online Support. Please note that while Go Daddy Customer Service Representatives cannot debug your CGI Scripts or HTML website coding the information below should help you with your CGI enabled hosting account. There are many variables that could cause a page not to work correctly. As you troubleshoot the problem, bear in mind some of the more common causes of problems with scripts:

    • If you are using Perl, make sure that the path to the interpreter is listed correctly as:

    #!/usr/bin/perl

    • Look for capitalization errors or other kinds of typos. (in both you CGI and HTML)
    • Check the permissions for the files in your CGI bin. (Hosting subfolder "CGI" is your "CGI-BIN" folder; as many customer CGI scripts call for the "CGI-BIN" folder, rename this to the "CGI" folder.)

    Many problems with Perl CGI scripts can be resolved by paying careful attention to the three issues mentioned above.

    I have no idea what this means. How does this relate to the .htaccess file?

  8. urbanscout
    Member
    Posted 6 years ago #

    I upgraded my godaddy account to their hosting configuration 2.0:

    http://help.godaddy.com/article.php?article_id=1076&topic_id=412

    I activated the error log, but I still can't access it. I'll wait another hour or so and see if that's working... though I don't know why that should change anything.

  9. urbanscout
    Member
    Posted 6 years ago #

    Okay, I got into the CGI admin and checked the error log and found a whole bunch of these:

    [Sun Nov 11 15:45:27 2007] [alert] /var/chroot/home/content/s/c/o/scoutwithclout/html/.htaccess: Invalid command '(This', perhaps mis-spelled or defined by a module not included in the server configuration

  10. urbanscout
    Member
    Posted 6 years ago #

    At this point, I don't know what to do. I am going to move the .htaccess file to the urbanscout.org/wordpress/.htaccess directory and wait. If that doesn't work after a while I will just delete the .htaccess file and change my permalinks back to their ugly ass selves. What a waste of time.

  11. urbanscout
    Member
    Posted 6 years ago #

    Okay, so when I move the .htaccess file into the wordpress directory, I can access the main page of my site, but the main page comes out as just text.

    ...still cannot access individual pages.

    Now my error log says:

    [Sun Nov 11 15:56:48 2007] [alert] [client 69.5.109.191] /var/chroot/home/content/s/c/o/scoutwithclout/html/wordpress/.htaccess: Invalid command '(This', perhaps mis-spelled or defined by a module not included in the server configuration

  12. moshu
    Member
    Posted 6 years ago #

    You are messing around with the two URI values in the Oprions > General.

    If you installed your WP in a subfolder called "wordpress" BUT you want the blog to appear at the root (example.com) then just read and re-read the instructions:
    Giving_WordPress_Its_Own_Directory
    The stylesheet is there but (because of your wrong settings) WP is looking for it in the wrong place)

  13. urbanscout
    Member
    Posted 6 years ago #

    Interesting... So I gave up and deleted the .htaccess file. Of course my graphics came back immediately. I then went into my admin and changed the permalinks back to the default. Than I changed them back to /%postname%/ and I this time when I clicked the update permalink button, it said, "Permalinks updated" instead of "you need to update your .htaccess file." WTF? Could it be that I activated some feature in the godaddy 2.0 hosting configuration? That must be it... Though, the links still don't work. I will wait for an hour again and see if they get updated.

  14. urbanscout
    Member
    Posted 6 years ago #

    Thanks Moshu,

    My general options say this:

    WordPress address (URI): http://www.urbanscout.org/wordpress
    Blog address (URI): http://www.urbanscout.org

    I read the Giving wordpress it's own directory... but I still don't get what I have done wrong.

  15. moshu
    Member
    Posted 6 years ago #

    You have to have 2 index files and two htaccess files - one in the root and one in the wordpress subdir.
    That's what the instructions say... if you read them.

  16. urbanscout
    Member
    Posted 6 years ago #

    Yes I just noticed that! I missinterperetted the "copy" as "move to."

    So I went backwards. I created another index file for my /wordpress directory and changed it back to

    require('./wp-blog-header.php');

    Now I need to create two .htaccess files? I don't understand that part. Are they empty? Do they both need to have the mod_rewrite code? WordPress doesn't automatically create them?

  17. urbanscout
    Member
    Posted 6 years ago #

    Even though when I click Update Permalinks, and it says, "Permalinks Updated" the links still don't work. it doesn't even tell me to update my .htaccess files anymore. What does that mean?

  18. moshu
    Member
    Posted 6 years ago #

    They should both look like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    
    # END WordPress
  19. urbanscout
    Member
    Posted 6 years ago #

    It looks like wordpress has created an .htaccess file in the root directory, but not the wordpress directory. Yet when I create an .htaccess file, blank or with the same code as the other, the site reverts to text only and the links still don't work.

  20. moshu
    Member
    Posted 6 years ago #

    Post less and read more...

  21. urbanscout
    Member
    Posted 6 years ago #

    It automatically created this one in the root:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    I changed it to your mark up with "wordpress" in the appropriate places, and created the same one for the directory folder as well. The site still reverts to text only when I put in your code to the .htaccess file in the WP directory. And the links still don't work.

    ...and the site now has a 500 internal server error again...

    post less read more...

    Haha. I'm trying. I've been at this for over 12 hours now and still no luck. I am not computer savvy, but it looks like even the savvy ones are having a hard time with this one. I really appreciate your help. You're the first person actually helping me figure it out.

  22. moshu
    Member
    Posted 6 years ago #

    What I posted I copied from a site where I set up WP exactly like your instllation:
    showing blog at the root
    having it installed in a directory called "wordpress"

    True, it is on a real host, not godaddy. (Everybody should do one thing well: they are great for registering domains but they are not so great as hosting company)

  23. urbanscout
    Member
    Posted 6 years ago #

    Um... I have no idea what I did, but it works.

    I have only one .htaccess file, and it's in the root.

    I think the key was you having me copy the index.php into the WP directory.

    Than I deleted all the .htaccess files and changed everything back to normal in the permalinks. This must have created a default .htaccess file, which I was than able to change to /%postname%/ and bam!

    All that screwing around with the .htaccess must have messed it up. Now I just hope my site doesn't crash after 20 minutes...

Topic Closed

This topic has been closed to new replies.

About this Topic