WordPress.org

Ready to get started?Download WordPress

Forums

Scheduled Posts Calendar
Permalink changes when planing post (8 posts)

  1. deeluuxe
    Member
    Posted 1 year ago #

    Unfortunately I found a bug - checked this when your plugin is activated and deactivated.

    When editing a post:
    1. Click in "Scheduled for" to set a date
    (very cool the date of the latest scheduled post is set automatically)

    2. Note the name of the permalink

    3. Click on "Schedule" - page reloads
    (not sure if it is named like this, I´m using WP in an other language, means the button to publish a post)

    4. Now the permalink changed to the one of the last post "-2" is added
    So a wrong permalink is saved.

    Do you have the same behavior?

    Best regards,
    Jan

    http://wordpress.org/extend/plugins/scheduled-posts-calendar/

  2. deeluuxe
    Member
    Posted 1 year ago #

    ...maybe good to know: My posts are generated by Formidable - so I only have to open the post to edit the time...

  3. Eduardo Stuart
    Member
    Plugin Author

    Posted 1 year ago #

    deeluuxe,

    "1. Click in "Scheduled for" to set a date
    (very cool the date of the latest scheduled post is set automatically)"

    # This is not a feature of the plugin. This is a feature of WordPress.

    "2. Note the name of the permalink
    4. Now the permalink changed to the one of the last post "-2" is added"

    # This happened because you saved the first post and second post you scheduled (same name "slug"). that's not because of the plugin.

    The plugin only selects the scheduled posts, it changes nothing in the schedules or scheduling functionality.

    Thanks for the detailed answer.

  4. deeluuxe
    Member
    Posted 1 year ago #

    Ok, I´m trying to clarify this:
    The permalink doesn´t change because the same post has been saved before. I disabled your plugin for two days now and everything worked fine. Activated it again today and the following happened:

    1. The post has been generated by Formidable and is not published
    2. Clicking on "edit post" in WP-Admin post listing
    3. The permalink is: ".../foto/kromfohrlander-lucy/" (that´s correct)
    4. Now I schedule the post for today 19:46 and click on "schedule"
    5. Page reloads and the permalink changed to ".../foto/chihuahua-muffin-2/"
    6. "/foto/chihuahua-muffin/" is a post I pubished 1 minute before without scheduling it

    This strange behavior occurs only when the scheduled post calendar plugin is activated.

  5. deeluuxe
    Member
    Posted 1 year ago #

    Got an idea: Maybe this occurs only when more than one post is being scheduled. I remember I didn´t got a problem with the first post I scheduled today. I will check this again tomorrow when all scheduled posts are live.

  6. Eduardo Stuart
    Member
    Plugin Author

    Posted 1 year ago #

    I'll try to simulate this error.

    Thanks deeluuxe !

  7. deeluuxe
    Member
    Posted 1 year ago #

    Checkt this again today - it was like expected:

    First post scheduled today was fine - no problems. Permalink remains the same after scheduling and publishing the post (by clicking "schedule").

    After that I scheduled three more posts:

    2. post got the permalink from the first one extended by "-2"
    3. post got the permalink from the second one extended by "-2"
    4. post got the permalink from the third one extended by "-2"

    I corrected the permalink of each post right after scheduling before editing/scheduling the next one.

    Hope you´ll find the problem. If there´s anything I can help just let me know.

    Best regards,
    Jan

  8. deeluuxe
    Member
    Posted 1 year ago #

    Hello!

    Have you been able to reproduce this error? If you need further information on this, just let me know.

    Best regards,
    Jan

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.