WordPress.org

Ready to get started?Download WordPress

Forums

Permalink changes show 404 errors (10 posts)

  1. brightonseo
    Member
    Posted 1 year ago #

    I'm trying to help a friend do some tweaks to her blog and she has Permalinks set to default. I changed it to custom setting with the following code:
    /%category%/%postname%/

    The problem is when I do this change,all her pages show as 404 Not Found.
    Is it just a matter of editing the url section of the page/post or is it something more complex?

    Thanks in advance.

  2. Marvel Labs
    Member
    Posted 1 year ago #

  3. brightonseo
    Member
    Posted 1 year ago #

    Hi Marvel Labs thanks for the reference but I'm none the wiser after reading it except that it might be the theme.
    Do you know what I need to do to the theme to get custom urls to display?
    The site is:
    Extraordinary Fitness Holidays

  4. LimeTreeFruits
    Member
    Posted 1 year ago #

    Hi brightonseo, I was having that same issue but it is now fixed.
    Were your friend's links all ending with .html? If so, you can manually change it. Like this:

    /%category%/%postname%html

  5. brightonseo
    Member
    Posted 1 year ago #

    Hi LimeTreeFruits, I just had a look and added the snippet you provided but it still shows 404 Not Found page.
    The problem is I'm trying to optimise her site but this problem would be disasterous for seo work.
    The only other option would be to ask her to change the theme to one that allows Custom Permalink settings to work or it will give me twice a smuch work to get her site to rank.

    I thought that maybe there was something \i could add to one of the theme files to get it working but it's looking quite remote now.

    Tricky situation all round.

  6. brightonseo
    Member
    Posted 1 year ago #

    Still no resolution to this probelm.
    Is this quite a common problem with WordPress sites?

    If so, what steps are usually taken to bypass this problem for getting urls to display with seo friendly titles?

    Anyone out there with any idea?

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    Switching from default to any permalink setup should not cause any 404 errors - the 'pretty' permalink and the default point to the same place and should simply resolve.

    Rarely would a theme be the issue - unless something really goofy is going on, the theme should have no bearing on permalinks of any sort

    The site is currently using default, so I can't check out the forming of the permalinks

    When you set to custom, does the .htaccess file get generated appropriately? Are you on an apache server? Is mod_rewrite activated on the server?

  8. brightonseo
    Member
    Posted 1 year ago #

    Hi Voodoo

    Not sure how to check if htaccess is generating correctly.
    Can you advise on how I can check the other things you suggested.

    Many thanks

  9. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    You would check with the host to know if you were on an apache server, and if mod_rewrite was installed.

    You would check the directory WP is installed in for the .htaccess file and compare it to this
    http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29

    if you are on an apache server. If you are on IIS, .htaccess files don't work

  10. brightonseo
    Member
    Posted 1 year ago #

    Thanks Voodoo

    I'll see what I can find and report back to base.:)

    Much appreciated friend.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.