WordPress.org

Ready to get started?Download WordPress

Forums

permalink change messed up home page (8 posts)

  1. trailsnet
    Member
    Posted 2 years ago #

    After watching a great tutorial about WordPress 3, I decided to create a custom structure for my Permalinks. So I went with %category%/%postname%.
    Sure enough, this made all my permalinks look a lot better. And everything on the site works just fine, except the home page. Now when I select the "Home" button on the menu, I get an error message instead of the blog that should come up. This is because now, WP tries to go to http://www.activetraveltours.com/active-travel-blog instead of just http://www.activetraveltours.com.
    On any other page on my website, I can easily edit the page, including the URL. But WP (or at least the Graphene theme) won't let me get to my home page. It's not listed as one of the pages when I got to "all pages."
    So I some how need to keep the rest of the site running w/ the new, improved permalinks and make it so that when I select "Home" it goes to http://www.activetraveltours.com instead of http://www.activetraveltours.com/active-travel-blog
    Any suggestions would be appreciated.

  2. silverks
    Member
    Posted 2 years ago #

    Seems like you're using the Custom Menu feature. Go to WP Admin > Appearance > Menus and check the link for the Home menu item.

  3. trailsnet
    Member
    Posted 2 years ago #

    Thanks silverks,

    Before I give your suggestion (above) a try, I want to make sure I understand your instructions:

    So I went to WP Admin > Appearance > Menus and the only place I could find a "Home menu item" was in the "Pages" box. When I first looked, "home" wasn't even in that one, but when I checked the "view all" tab, it appeared.

    So then you said I "check the link for the Home menu item." I'm not sure what that means or how to do it. Do you literally mean just add a check in the tick box to the left of the Home menu item? Or do you mean there should be a URL associated with that Home menu item that I'm supposed to look at? If the latter, I don't know how to check that, because no URL address appears.

    Sorry for my ignorance, but your help is greatly appreciated. Thanks.

  4. silverks
    Member
    Posted 2 years ago #

    Do you literally mean just add a check in the tick box to the left of the Home menu item?

    Tick the checkbox and click the Add to Menu button.

  5. trailsnet
    Member
    Posted 2 years ago #

    Once again, thank you for your help, silverks!! I appreciate your patience.

  6. trailsnet
    Member
    Posted 2 years ago #

    Dang,
    That didn't work. It just added another HOME button, but the button takes me to an ERROR page instead of my blog/home page.
    In reworking my entire site for SEO, the home page address was changed from http://www.activetraveltours.com/blog to just http://www.activetraveltours.com.
    But the HOME button still tries to take me to the link w/ the "blog" in the URL. I know how to change the URL in every other page in my website except the home page. For some reason, that page doesn't show up in my list of "all pages." And when I go to the "Posts" admin page, I can fiddle w/ the individual posts on my home/blog page, but not with the URL of the actual page that contains those posts.

  7. silverks
    Member
    Posted 2 years ago #

    If you click on the little arrow to the right of the "Home" menu item in Wp Admin > Appearance > Menus, you'll see that it expands and then you can edit the link it points to.

    Also, you might want to check your Site URL setting in WP Admin > Settings > General.

  8. trailsnet
    Member
    Posted 2 years ago #

    That did it!!

    Thank you immensely for sticking with me and doing such a good job of explaining the process. Now it works like a charm. You're a life saver!!

Topic Closed

This topic has been closed to new replies.

About this Topic