WordPress.org

Ready to get started?Download WordPress

Forums

Permalink change isn't worknig (4 posts)

  1. kurtposer
    Member
    Posted 6 years ago #

    When I change my permalink options to display the date and posting name as part of the url, it doesn't work. I don't get an error message when doing this, but do when I try to access pages afterwards. Here is a more full explanation of what the hosting company's technical assistance said:

    When Kurt changes his wordpress permalinks to be in the name and date format rather than the id, an error comes up saying that the database configuration is not found, please run the installer. Checked over everything I can think of. looked at .htaccess and it looks okay. He had done a manual wordpress install so we eventually just generated a backup, deleted the wordpress folder and did a clean install (it was the same version 2.3.1) with fantastico. It setup a new database to which the data was imported. With the fresh install, when he changed the permalinks format, it still does the same thing. It is getting updated in the database. I can't see why it would be doing it on a clean install. As far as I know, importing the posts, etc. wouldn't have messed with wp-config.php but i suppose it's possible. Can you please look at the .htaccess or anything else to see what could be going on? There's gotta be something I'm missing. If he changes it back to id format, it works perfectly. wp is installed in the /wp folder. He has his .htaccess setup to have his main domain point to that folder rather than public_html.

    Thanks for your time in helping.

    Kurt

  2. kurtposer
    Member
    Posted 6 years ago #

    This problem has become confusing, but may be due to the .htaccess file. The reason I say this is that this file, under the wp folder, was modified and it allowed name-based permalinks, but also disabled the page links at the top of the site: http://www.considercommonsense.com.

    Links were corrected in internal articles before I realized the page links were no longer working. I switched back and everything works again in default ID permalink mode. When I change back and use the modified .htaccess file, nothing works.

    I am not sure what my next step is, but am pretty certain that this is it. Can someone please help me understand what is why this is happening and help me understand how I could fix it?

    This is what was in the .htaccess file that allowed name based permalinks and not page links to work:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    What should this file look like to get everything to function properly? I use WP 2.3.1.

    Thanks.

    Kurt

  3. Rebecca Putinski
    Member
    Posted 6 years ago #

    I just had this problem even though my .htaccess was writable and everything. It just seemed that it did /not/ update at all.

    Solution:

    Delete .htaccess, recreate (using touch or something similar), CHMOD to something wordpress can write to, then re-initialize the permalink structure in wordpress. Then you can bump back down the file permissions if you won't be making anymore permalink changes.

  4. Anonymous
    Unregistered
    Posted 6 years ago #

    hi, i have the same problem with permalink and i don't actually know how to change .htaccess file, how to make it writable for wp, please advise.

Topic Closed

This topic has been closed to new replies.

About this Topic