WordPress.org

Ready to get started?Download WordPress

Forums

Permalink caching? (3 posts)

  1. jgirdwood
    Member
    Posted 2 years ago #

    My first request for help on forum so bear with me (level: amateur)!
    Building site http://so.hn
    Theme is iFeature

    Problem seems to be permalink caching; here is what happened:

    1. Created page http://so.hn/about/johngirdwood/
    2. Deleted it; removed from trash, etc.
    3. Recreated page http://so.hn/about/johngirdwood/
    4. Now, receive error...

    Catchable fatal error: Object of class WP_Error could not be converted to string in /home/omiafoun/public_html/so.hn/wp-content/themes/ifeature/core/core-functions.php on line 202

    Line 202 seems to be...

    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');

    within section of core-functions.php...

    } elseif ( is_attachment() ) {
    $parent = get_post($post->post_parent);
    $cat = get_the_category($parent->ID); $cat = $cat[0];
    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');
    echo '' . $parent->post_title . ' ' . $delimiter . ' ';
    echo $before . get_the_title() . $after;

    Here are some potentially helpful details:

    1. If I "unparent" the page http://so.hn/about/johngirdwood/ and turn it into http://so.hn/johngirdwood/ then the page works with no problem.
    2. If I perform the "unparenting" then I can place the now working page http://so.hn/johngirdwood/ under menu "About" and view it fine. So, it doesn't appear to be a menu problem.
    3. I've permanently removed pages, menus, plug-ins, emptied trash, and done all of those necessary basic steps to no avail.
    4. I've created new pages like http://so.hn/about/john-girdwood/ which will work fine as a "child" page under "About"

    WHAT I WANT - to get my http://so.hn/about/johngirdwood/ working!

    Thanks for your brilliant help everybody!

    - John G -

  2. CyberChimps
    Member
    Posted 2 years ago #

    Thank you for the post. This appears to be an issue related to our breadcrumbs function.

    Do you think it would be possible for me to get access to your site so I can try and troubleshoot this at the source? Contact us via our contact form http://cyberchimps.com/support/questions/

  3. jgirdwood
    Member
    Posted 2 years ago #

    Wow, happy day! I figured out the problem and maybe this will help you cyberchimps. By the way - great theme!

    I had an image in my WordPress Image Library titled "johngirdwood" exactly (regular .jpg link below).

    To troubleshoot, I removed the breadcrumbs function of core-functions.php and my page worked... but, it showed the image and my WordPress toolbar offered me the option to "edit image" but not "edit page". Hmmmm... so, I retitled that image to be "John Girdwood" [added a space] and now it works! I did not change the image URL nor did I alter the image in any way other than changing the *required* Title.

    So, my "johngirdwood" page was somehow being confused with my "johngirdwood" Titled image. Kept page and page title. Kept image but changed image title.

    Now, everything works! Yay! Again, iFeature is a great theme and thanks for the prompt reply. - John G -

    http://so.hn/wp-content/uploads/2012/02/johngirdwood.jpg

    Now, if I could figure out how to close this comment thread...
    #newbieproblems

Topic Closed

This topic has been closed to new replies.

About this Topic