WordPress.org

Ready to get started?Download WordPress

Forums

Permalink and warning problems (15 posts)

  1. varzero
    Member
    Posted 3 years ago #

    Hi,

    I installed WordPress (3.1.3, Italian language) with the latest iThemes Builder theme, same plugins and configurations (permalink: /year/month/day/postname/) on 2 different webservers (Apache) of my hosting provider.

    The first one (PHP 5.2) is working fine, but the second one (PHP 5.3) has the following problems.

    1) A warning in the theme layout editor of the admin section (the bold parts of the paths are files and not directories):

    “Warning: is_dir(): open_basedir restriction in effect. File(/var/www/vhosts/variante000096/httpdocs/wp-content/themes/Builder/lib/layout-engine/modules/class.module.php.bak/images) is not within the allowed path(s): (/var/www/vhosts/variante000096:/usr/share/php) in /var/www/vhosts/variante000096/httpdocs/wp-content/themes/Builder/lib/layout-engine/editor.php on line 1545 Warning: is_dir(): open_basedir restriction in effect. File(/var/www/vhosts/variante000096/httpdocs/wp-content/themes/Builder/lib/layout-engine/modules/class.module.php/images) is not within the allowed path(s): (/var/www/vhosts/variante000096:/usr/share/php) in /var/www/vhosts/variante000096/httpdocs/wp-content/themes/Builder/lib/layout-engine/editor.php on line 1545”.

    2) The link in the home page (using the tag <!--nextpage--> to create a pagination) redirects to .../2011/06/27/200/ whit a 404 error (page not found) instead of redirecting to .../page/2/ (correct).

    In both cases I have the same .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I have temporarly solved the problem n. 1) contacting the system administrator of my hosting provider who changed the PHP configuration of the second webserver: php_admin_flag display_errors Off.

    Any suggestion?

    Thanks.

    Matteo

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    You have a server/theme issue. Either move to a different server or use another theme.

  3. varzero
    Member
    Posted 3 years ago #

    I contacted my hosting provider, but they don't see any issue in their webserver configuration...

    I tried to activate the Twenty Ten default theme, but the permalink redirect is still working wrong...

    Thanks.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Warning: is_dir(): open_basedir restriction in effect.

    That is a server configuration issue.

  5. varzero
    Member
    Posted 3 years ago #

    Talking to my hosting provider system administrator I was especting:

    - issue n. 1) = webserver configuration;

    - issue n. 2) = WordPress permalink engine problem.

    For issue n. 1) I sent another email to my hosting provider.

    For issue n. 2) I don't know how to solve...

    Thanks.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    It's not a WP permalink issue. Your theme is using PHP functions that your hosts do not allow.

  7. varzero
    Member
    Posted 3 years ago #

    Also for the wrong permalink redirect?

    Do you have any idea about which PHP functions could create this issue?

    My hosting provider system administrator asked me which are WordPress Apache/PHP configuration setting requirements, but I don't know them except for the following:

    - PHP 5.2.4;
    - MySQL 5.0.15;
    - Apache mod_rewrite module.

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    Does the permalink issue remain if you switch to the Twenty Ten theme?

  9. WebTechGlobal
    Member
    Posted 3 years ago #

    Months ago I had an issue with "open_basedir restriction in effect", customers reported this while others did not but using the same version of my plugin.

    I think it is the server myself but nothing is ever 100% sure.

    I would consider these paths needing changed if your hosting is sure there setup is acceptable...

    /var/www/vhosts/variante000096/httpdocs/wp-content/themes/Builder/lib/layout-engine/modules/class.module.php.bak/images

    Maybe the images folder can be accessed without using...

    /var/www/vhosts/variante000096/httpdocs

  10. varzero
    Member
    Posted 3 years ago #

    Yes, the permalink issue remains after switching to the Twenty Ten theme.

    Even if I change the path

    /var/www/vhosts/variante000096/httpdocs/wp-content/themes/Builder/lib/layout-engine/modules/class.module.php.bak/images

    to

    /wp-content/themes/Builder/lib/layout-engine/modules/class.module.php.bak/images

    class.module.php.bak is not a directory, but a file...

  11. varzero
    Member
    Posted 3 years ago #

    I noticed I have in the menu:

    - Home
    - Home: Home

    which is strange...

    With Twenty Ten theme if I open .../page/2/ it's opening .../2011/06/27/200/ failing,

    but if I open .../page/2 it's opening the second page of the home correctly...

  12. WebTechGlobal
    Member
    Posted 3 years ago #

    Can you copy your permalink structure here please.

    Also paste the setting that holds your domain name. Ensure there is nothing strange about that. Probably won't be.

    Please also paste the contents of your htaccess file

  13. varzero
    Member
    Posted 3 years ago #

    It seems a problem with the theme.

    Now I think it's working with Twenty Ten.

    Using the iThemes Builder theme and a static page as home, there is something wrong with the permalink.

    The pagination works for the other pages, but not the home page...

  14. varzero
    Member
    Posted 3 years ago #

    For permalink structure and htaccess content, please refer to my first post.

  15. WebTechGlobal
    Member
    Posted 3 years ago #

    Sorry I forgot it was there, just looking over it now

Topic Closed

This topic has been closed to new replies.

About this Topic