WordPress.org

Ready to get started?Download WordPress

Forums

Permalink and non-existent pages (17 posts)

  1. arkane8
    Member
    Posted 7 years ago #

    Permalinks are working well...except one minor problem. PHP files that I have in the root folder of my site now show 'page cannot be displayed' (or perhaps just individual php files that are created outside of wordpress's posts and pages). http://www.shadowvillepro.com/subscribe.php used to work fine prior to permalinks...now http://www.shadowvillepro.com/subscribe.php just has Page Cannot Be Displayed.

    Please note this problem lies within only IE, not Firefox. What could be the explanation for this?

  2. arkane8
    Member
    Posted 7 years ago #

    I would appreciate any help with this....

  3. Chris_K
    Member
    Posted 7 years ago #

    There must be more to this?

    http://www.shadowvillepro.com/subscribe.php works fine from IE (I also tried from FF successfully).

    Is your wordpress installed in the root of your website or in a sub-directory?

  4. arkane8
    Member
    Posted 7 years ago #

    It's installed in the root of the website.

    And it's not working with any of my computers using IE 6.0.

  5. Chris_K
    Member
    Posted 7 years ago #

    Ok... Now that's just weird.

    Would you be willing to share the complete contents of your .htaccess file here? (if it's huge, put the contents in pastebin or a text file in your blog and just post a link here).

  6. arkane8
    Member
    Posted 7 years ago #

    #
    # Apache/PHP/Drupal settings:
    #

    # Protect files and directories from prying eyes.
    <FilesMatch "(\.(engine|inc|install|module|sh|.*sql|theme|tpl(\.php)?|xtmpl)|code-style\.pl|Entries.*|Repository|Root)$">
    Order deny,allow
    Deny from all
    </FilesMatch>

    # Set some options.
    Options -Indexes
    Options +FollowSymLinks

    # Customized error messages.
    ErrorDocument 404 /index.php

    # Set the default handler.
    DirectoryIndex index.php

    # Override PHP settings. More in sites/default/settings.php
    # but the following cannot be changed at runtime.

    # PHP 4, Apache 1
    <IfModule mod_php4.c>
    php_value magic_quotes_gpc 0
    php_value register_globals 0
    php_value session.auto_start 0
    </IfModule>

    # PHP 4, Apache 2
    <IfModule sapi_apache2.c>
    php_value magic_quotes_gpc 0
    php_value register_globals 0
    php_value session.auto_start 0
    </IfModule>

    # PHP 5, Apache 1 and 2
    <IfModule mod_php5.c>
    php_value magic_quotes_gpc 0
    php_value register_globals 0
    php_value session.auto_start 0
    </IfModule>

    # Reduce the time dynamically generated pages are cache-able.
    <IfModule mod_expires.c>
    ExpiresByType text/html A1
    </IfModule>

    # Various rewrite rules.
    <IfModule mod_rewrite.c>
    RewriteEngine on

    # If your site can be accessed both with and without the prefix www.
    # you can use one of the following settings to force user to use only one option:
    #
    # If you want the site to be accessed WITH the www. only, adapt and uncomment the following:
    # RewriteCond %{HTTP_HOST} !^www\.example\.com$ [NC]
    # RewriteRule .* http://www.example.com/ [L,R=301]
    #
    # If you want the site to be accessed only WITHOUT the www. , adapt and uncomment the following:
    # RewriteCond %{HTTP_HOST} !^example\.com$ [NC]
    # RewriteRule .* http://example.com/ [L,R=301]

    # Modify the RewriteBase if you are using Drupal in a subdirectory and
    # the rewrite rules are not working properly.
    #RewriteBase /drupal

    # Rewrite old-style URLs of the form 'node.php?id=x'.
    #RewriteCond %{REQUEST_FILENAME} !-f
    #RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteCond %{QUERY_STRING} ^id=([^&]+)$
    #RewriteRule node.php index.php?q=node/view/%1 [L]

    # Rewrite old-style URLs of the form 'module.php?mod=x'.
    #RewriteCond %{REQUEST_FILENAME} !-f
    #RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
    #RewriteRule module.php index.php?q=%1 [L]

    # Rewrite current-style URLs of the form 'index.php?q=x'.
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
    </IfModule>

    # $Id: .htaccess,v 1.73 2006/04/14 09:08:26 killes Exp $

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  7. arkane8
    Member
    Posted 7 years ago #

    I once tried Drupal till I realized Godaddy doesn't allow locking tables. So I deleted the Drupal files....but I have no idea how to clean up the Drupal stuff in .htaccess...I'm not too knowledgable with tampering with .htaccess and don't wanna mess things up :)

  8. Chris_K
    Member
    Posted 7 years ago #

    Eeks.

    Well, the WP part is easy to figure out. I dunno if ALL of that above is for drupal or if some of it is just generic to your host.

    Because I'm a daredevil...

    I'd back up that .htacess (copy it to .htaccess.bak or something similarily clever) and then I'd remove everything above
    # BEGIN WordPress
    and see what happens.

  9. arkane8
    Member
    Posted 7 years ago #

    Nothing happened. And I mean nothing...no changes, no difference, still can't access this page.

    Also I used to have a users-online.php file that used to be in the root directory, but didn't work either after I changed from IDs to permalinks. I fixed the problem by calling the function using <?php ?> embedded on a wordpress Page.

    But I can't do that with subscribe.php as the functions are considerably more complex and needs its own .php file to function.

  10. arkane8
    Member
    Posted 7 years ago #

    Any other ideas?

  11. Chris_K
    Member
    Posted 7 years ago #

    I, for one, am rather stumped. Hopefully one of the smart folks will wander by and offer some thoughts!

  12. moshu
    Member
    Posted 7 years ago #

    The page displays fine both in IE and FF.

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    I can see the subscribe page just fine.

    Anyway, all you need in .htaccess is that stuff after the # BEGIN WordPress, like Handy stated.

  14. arkane8
    Member
    Posted 7 years ago #

    I scrapped everything before #BEGIN WordPress...and it doesn't change much.

    The IE version that doesn't see the page is:

    6.0.2900.2180.xpsp_sp2_gdr.050301-1519
    Running Windows XP Professional on an AMD 64 Athlon processor.

    This applies to also the same version browser on two different Windows XP Home machines running on P4's.

  15. Chris_K
    Member
    Posted 7 years ago #

    Moshu and Otto:

    I can confirm I don't see the pages with ie6. I do see the pages with ie7b3, FF and Opera. Weird.

  16. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Shows up in IE6 for me. FF too. Don't have IE7 or Opera.

  17. arkane8
    Member
    Posted 7 years ago #

    bah this is killin me

Topic Closed

This topic has been closed to new replies.

About this Topic