WordPress.org

Ready to get started?Download WordPress

Forums

Permalink and htaccess 500 errors (4 posts)

  1. khaled
    Member
    Posted 8 years ago #

    I'm sure this has come up before, but I've not been able to find the relevant page.

    Basically I'm getting a 500 Internal Error. Delete the htaccess file and the site is back up. Go to the permalink options and get rid of the permalink structure and I'm pack in business.

    The SECOND I decide to have anything apart from the default and an htaccess file is present in the root directory I get those 500 Internal Errors again.

    I haven't really done anything to instigate this so I'm not sure what's triggered this off. All my pages don't work now either.

    Anyone got any posts where something similar has happened?

  2. skippy
    Member
    Posted 8 years ago #

    The error usually means that you're trying to do something in a .htaccess file that is not permitted, or you have a syntax error in your .htaccess file.

    In order for permalinks to work in .htaccess files, you need to have AllowOverride FileInfo enabled for your virtual host.

  3. oppgroup
    Member
    Posted 8 years ago #

    I have this same exact problem. But I'm not doing anything differently than I've done for the last 30 WP installs.

    Can you be more specific as to the.....

    AllowOverride FileInfo

    Is this supposed to be in the .htaccess file?

    And is this the EXACT command as typed above?

    However, I still cannot figure how suddenly after doing this the same exact way, same server, that I should be getting this error problem.

    Thanks for the help, btw

  4. CinnamonGirl
    Member
    Posted 8 years ago #

    My problem too! mod_rewrite is active in my apache installation, I checked everything twice and thrice. htaccess: Error 500. No htaccess: No problem.
    Has somebody by any chance come across a solution for this?

Topic Closed

This topic has been closed to new replies.

About this Topic