WordPress.org

Ready to get started?Download WordPress

Forums

Permalink and category links broken in 2.6 (35 posts)

  1. endquote
    Member
    Posted 6 years ago #

    I updated to 2.6 on a dev site and now permalinks and category links are broken.

    My permalinks have been in the format of: http://host/wp/index.php/2008/05/post-title/

    Categories are like so: http://host/wp/index.php/category/category-name/

    Now both return the 404 page.

    The main page of the site and the control panel and things all seem to work fine.

    The wp/.htaccess is the same on both the dev site (2.6 and broken) and the live site (2.5 and working). I've read other posts about setting the permissions on .htaccess and letting WP write a new one. I set it to 777, but WP doesn't modify the file. (And it didn't in 2.5 either.)

    Honestly I'd rather drop the index.php from the links anyway, but I was never able to get that to work.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    On the Settings->Permalinks screen, try setting a category and tag base value. Just have the words "category" and "tag" in there.

    See if that helps.

  3. endquote
    Member
    Posted 6 years ago #

    Yeah that fixed it. Nice. Though I don't really understand why?

    Bonus points if you can tell me how to get rid of the index.php in the link. I struggled with that for a while but gave up eventually.

    Currently if I just remove "index.php" from the browser location, I get the server 404 (not the WP one).

    Currently the /wp/.htaccess is:

    #RewriteEngine On
    #RewriteRule ^/wp/(.*)$ /wp/index.php?$1 [L]

    Nothing changes if I uncomment those lines. Changing permalink settings doesn't update the htaccess file, though WP should be able to write to it.

    Thanks for your help.

  4. Anonymous
    Unregistered
    Posted 6 years ago #

    Otto42, thanks, it helped for me too, phu!

    My very best!

    Robert

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    endquote: If WordPress can't update the .htaccess file, then it will give you the correct lines to put in it at the bottom of the screen when you update the permalink settings.

  6. kittycleopatra
    Member
    Posted 6 years ago #

    Otto,(or ANYONE) at the risk of sounding really retarded, when you said change the permalink setting to just "category" and "tag". Were you talking about creating a custom stucture :/%year%/%monthnum%/%day%/%postname%/ and changing the variables to category and tag or to just type that in in the category base and tag base. Sorry to sound so simple, but I've been screwing around with this all day, my brain is fried.

  7. kittycleopatra
    Member
    Posted 6 years ago #

    As of right now non of my permalinks work and I'm not sure how this fix actin would work for the calender links

  8. kittycleopatra
    Member
    Posted 6 years ago #

    I changed the base values to category and tag, it didn't work for me

  9. kittycleopatra
    Member
    Posted 6 years ago #

    Firefox gives me an error saying this page isn't redirected properly.

  10. kittycleopatra
    Member
    Posted 6 years ago #

    Nevermind, I just changed them to default and they're working now

  11. saphod
    Member
    Posted 6 years ago #

    I had the 404 permalink problem only with pages, posts worked fine. Tried the "category and tag" trick, didn't work. Then I deactivated all plugins, updated the permalinks and reactivated all of the plugins - and then, all of a sudden, it worked... ???

  12. Anonymous
    Unregistered
    Posted 6 years ago #

    @kittycleopatra, just leave your normal permalink option enabled, and put the word category in the category base value box, and tag in the tag base value box..

    It should all work as usual.

  13. malbiniak
    Member
    Posted 6 years ago #

    Unfortunately, this setting category and tag as the base in the permalink settings did not work. We made a mega leap from 2.1.x to 2.6. Probably a bad move, and if worst comes to it, I can roll back and micro step. However, since some people have this same problem going from 2.5 to 2.6, I'll be patient and hope for some other suggestions.

    Also, in manage -> categories, I see blank rows (5) with blank category names, but each row has at least 10 posts in that category. When I manage -> posts, the blank categories are still blank with the checkbox. Looking at the database, all entries in wp_posts has post category = 0.

    SELECT * FROM wp_posts WHERE post_category != 0
    --> 0 results returned

    SELECT * FROM wp_posts WHERE post_category = 0
    --> 119 results returned

    HELP!

  14. malbiniak
    Member
    Posted 6 years ago #

    this post got me back on track. categories have returned and the people rejoiced.

  15. Nicki Faulk
    Member
    Posted 6 years ago #

    Otto42: thank you SO MUCH!

    My husband hosts his site from here at home (Windows/Apache/Server 2K3) and after upgrading his site to 2.6, he started having this problem as well.

    I ran across your post on another thread pointing to here, implemented your suggestion, and now his site is all happy happy! :)

    As a reward, he's taking me to my favorite restaurant this weekend. *huge grins!* :D

    So thank you, thank you, thank you, THANK YOU! :D

  16. dswearingen
    Member
    Posted 6 years ago #

    Go Otto42, go! Worked for me on IIS at CrystalTech hosting.

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    This is a known bug, which will be fixed in future revisions.

    See here: http://wordpress.org/support/topic/189058?replies=1

  18. superdave
    Member
    Posted 6 years ago #

    kittycleopatra ... what otto means is add /%category%/%tag%/ to your permalinks. like this:

    /index.php/%category%/%tag%/%year%/%monthnum%/%postname%/

    easy!

  19. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    superdave: No, that's not what I meant at all. Read the thread I posted above.

  20. superdave
    Member
    Posted 6 years ago #

    haha ... sorry otto ... actually, i tried what i 'thought' you meant, and it didn't work! :(

    so i completely screwed it up.

    actually, adding /%category%/ to the permalinks helped a little. my pages worked, but then my posts didn't work at all.

    sorry for the confusion.

  21. Anonymous
    Unregistered
    Posted 6 years ago #

    I'm having the above-mentioned problem, but none of the fixes offered so far work.

    I have no index.php in my URLs, as others seem to describe further up. I have added 'category' and 'tag' to the category and tag bases. Neither posts nor pages nor categories work.

    I have very limited knowledge of Permalinks, but this seems totally broken, even with all the fixes.

    I'd appreciate a helping hand.

    Thanks

  22. Anonymous
    Unregistered
    Posted 6 years ago #

    I even installed the fixes listed here: http://trac.wordpress.org/changeset/8365.

    No luck.

  23. Anonymous
    Unregistered
    Posted 6 years ago #

    I have the same problem

  24. Anonymous
    Unregistered
    Posted 6 years ago #

    I never really setup permalinks for my blog, but I'm really having an issue getting my Category names back. I've tried to get them all re-entered direcly into the sql tables as mentioned by other users, and have tried everything else suggested... but they refuse to show up on my blog. I also can not get anything to come up when searching for posts that are not on the front page by default.

    Anyone able to help?

  25. simanza
    Member
    Posted 6 years ago #

    Help! All my links are broken with the update to 2.6 - not just categories and permalinks. ALL.

    Page links, posts, categories, archive.

    Suggestions?

  26. Anonymous
    Unregistered
    Posted 6 years ago #

    I have the same problem: No category names appear in the Manage Categories section or on the live pages. I deactivated all plugins and added "category" to the permalink page, reactivated plugins and nothing happened.

    Any ideas?

  27. Anonymous
    Unregistered
    Posted 6 years ago #

    I have had this problem for a long time. No matter what I do and how many threads I read, I get noting but a "404" page when I try to change my permalinks to "/%category%/%postname%/". That's all I want to do, very simple, very easy looking, but to no avail!! Considering that a lot of other people have this problem, why isn't the default "/%category%/%postname%/" or something similar? I have done everything from changing the .htaccess file, to get a a plug-in (Permalink Redirect WordPress Plugin by Scott Yang), changing and re- saving, ???

  28. Anonymous
    Unregistered
    Posted 6 years ago #

    PS I am running 2.6

  29. saphod
    Member
    Posted 6 years ago #

    What happens if you deactivate all plugins and then update the permalink structure? Then try without ANY plugin activated. If this works, it is an issue with your plugins used. Try activating one by one and see where the error is.

    Happened to me - I have to reactivate the plugins in a certain order.

  30. Anonymous
    Unregistered
    Posted 6 years ago #

    just tried it and no luck

Topic Closed

This topic has been closed to new replies.

About this Topic