WordPress.org

Ready to get started?Download WordPress

Forums

Permalink 404 Problem: 2.8 Style (33 posts)

  1. WebmistressM
    Member
    Posted 5 years ago #

    First off, I know that this is a common problem. However, I did look i up before hand and the steps described in the following support links did not resolve it:
    http://wordpress.org/support/topic/193960?replies=8
    http://wordpress.org/support/topic/189058?replies=1

    I have restarted the Apache server to make sure that my httpd.conf changes took hold, but no luck. I still get a 404 on both pages and posts, if I use any Permalink option other than "default".

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Is the .htaccess file in your root WP folder writable? What are its current contents?

  3. WebmistressM
    Member
    Posted 5 years ago #

    My .htaccess file reads:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    Options +FollowSymLinks +SymLinksIfOwnerMatch

    It is set to 666 while I tweak around and I have verified that each time I make a setting change in Permalinks, it is writing to that file.

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    Can you take out that last line Options +FollowSymLinks +SymLinksIfOwnerMatch and see if that helps?

  5. WebmistressM
    Member
    Posted 5 years ago #

    I had those taken out at some point and that didnt work. One of the tutorial links in my original post mentions to try adding the "Options +FollowSymLinks +SymLinksIfOwnerMatch " line to it. Obviously that didnt work.

  6. esmi
    Forum Moderator
    Posted 5 years ago #

    Hmm... what custom structure were you trying to use?

  7. esmi
    Forum Moderator
    Posted 5 years ago #

    One other thought - you do have mod_rewrite enabled, don't you?

  8. WebmistressM
    Member
    Posted 5 years ago #

    I had tried to use all 3 of the non-default structures and even a simple custom. It always yielded this same result (404)

    I assume that the mod_rewrite has to be enabled elsewhere outside of .htaccess since you have already seen my .htaccess file. Where should this be? Maybe for my system, I put it in the wrong place.

  9. esmi
    Forum Moderator
    Posted 5 years ago #

    I assume that the mod_rewrite has to be enabled elsewhere outside of .htaccess since you have already seen my .htaccess file.

    You can place whatever you want in an .htaccess file. Including rewrite rules. doesn't mean that any of them will be acted upon, though, unless the appropriate module is available.

    Are you running WordPress locally? If so, what server applications are you using? EasyPhp? MAMP? XAMP?

  10. WebmistressM
    Member
    Posted 5 years ago #

    Yeah. I did install mod_rewrite and restarted apache. On the htaccess files, it sure has the mod rewrite of RewriteEngine On. Currently Im using LAMP. Still, no dice. Many of the things advised are what appear in the links of my original post. Its boggling me on why Im still stuck with ugly permalinks.

  11. esmi
    Forum Moderator
    Posted 5 years ago #

    Not used LAMP for a while (switched to EasyPHP). Right now I can't think of any reason why your permalinks aren't working. Especially as the defaults work. But pure gut instinct suggests that it's a server setup issue and there's a problem with mod_rewrite.

    If you're using WinXP, have you considered EasyPHP or Xamp?

    It might be worth starting a new topic under a "Issue with mod_rewrite locally?" topic header in the hopes of bringing out a few of the more expert server admins. But, if you do, reference this topic so they can see what you've already tried.

    Sorry I can't offer you anything more constructive.

  12. WebmistressM
    Member
    Posted 5 years ago #

    My server is on Ubuntu. Thanks for trying anyway.

  13. WebmistressM
    Member
    Posted 5 years ago #

    Oooh, interesting. I did notice that my httpd.conf file did not contain any of these lines:
    LoadModule rewrite_module modules/mod_rewrite.so
    AddModule mod_rewrite.c

    Adding them in myself produced this error when I restarted apache:
    Syntax error on line 308 of /etc/apache2/apache2.conf:
    Invalid command 'AddModule', perhaps misspelled or defined by a module not included in the server configuration

  14. DAide
    Member
    Posted 4 years ago #

    Thank you for posting this; I am experiencing the exact same problems.

    I have installed the latest WordPress and everything works perfectly except for the Permalinks. Whenever I adjust to anything except for the default, it results in a 404 error. I have tried every fix suggested in the Codex and in dozens of postings about this topic. None work.

    The installation did not create a .htaccess file, so I added a blank one. I have set the permissions to allow changes to the file, but when I adjust to a different permalink setting, it seems that nothing is written to the .htaccess file.

    I am also using a GoDaddy Windows Virtual Dedicated Server. I have seen postings about problems with GoDaddy and with Windows (instead of Linux), but I need to keep this server because I have other sites running on it.

    What else could it possibly be? Are there places where I can speak with someone on the phone or offer access to my site to see if anyone can troubleshoot this? Many thanks.

  15. bgsambrook
    Member
    Posted 4 years ago #

    Was anyone successful in figuring this out. . . I'm experiencing the exact same problem!

    Thanks.

  16. goddesskarla
    Member
    Posted 4 years ago #

    Beyond trying everything that I could find on this topic and doing everything short of reloading the site I still have not found a solution. I would happily use "ugly" links if I could get the default to work for me, it will only stay set for a moatter of hours and since I have updated WordPress it will not stay beyond the browswer that I am working in. ANY solution would be very much appreciated.

    Thank you for your assistance,
    ~gk~

  17. Tinklebelle
    Member
    Posted 4 years ago #

    I'm having this problem since updating to 2.8.5. I've changed my .htaccess file, changed back and forth from/to ugly permalinks, and am entirely too frustrated and annoyed right now to even think of diving into the core code.

    Ugly permalinks work. No others do.

  18. Robert Chapin
    Member
    Posted 4 years ago #

    Hi WebmistressM, if anyone came to me with a situation where the .htaccess file appears to do nothing, the first thing I would tell them is to make sure Apache Overrides are enabled for that particular website. If not, then the .htaccess file is being ignored and that is the correct behavior.

    When you confirm the .htaccess file is working, next I would try removing the IfModule statements. This will cause the server to throw status 500 in the event mod_rewrite isn't working. That should give you more info than a plain 404.

  19. ianacces
    Member
    Posted 4 years ago #

    I've been having the same problem.

    I'm not exactly sure what fixed it for me but my settings are as follows:

    .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /wordpress-e/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress-e/index.php [L]
    </IfModule>
    
    # END WordPress

    httpd.conf:
    I changed AllowOverride None to AllowOverride All *wherever* I found that line and the pretty permalinks are now working.

    Now to try and find out what I actually did that made a difference.

    Hope this helps someone.

    btw: httpd-2.2.3-31.el5.centos; WordPress 2.8.5

  20. Ted
    Member
    Posted 4 years ago #

    I tried ianacces's suggestion (using Mac OS X 10.6, built in PHP 5.3, Apache2, MySQL 5), but when I did, I couldn't access anything at all.

    I then found another post that suggested modifying the "AllowOverride" setting in the user .conf file, which I did. It is located at:

    /etc/apache2/users/your-user-name.conf

    Change the "AllowOverride None" to "AllowOverride All", and everything is working like a charm.

  21. chrispalle
    Member
    Posted 4 years ago #

    I'm getting 404s on my permalinks too, but it was working just fine yesterday. In fact, it's been working fine for months!

    Checked .htaccess and everything looks okay
    I'm on Dreamhost, don't know if I can get into the conf.

    I didn't do anything under the hood on Apache. Are there files I may have touched in the WP directories (besides .htaccess) from which there could be an issue?

    Thanks!

  22. maxsidman
    Member
    Posted 4 years ago #

    I recently started getting 404 errors on every single page past the site's root. I have not fiddled with anything in the back end, I can't think of any adjustments I've made to the site that would cause this to begin happening out of the blue. Making it even more frustrating, I can't find any files called .conf anywhere in the WP install or on the host side...where should I be looking for this?

    This is extremely frustrating and it seems like a pretty common problem. Is anyone from WP listening out there? Can you offer some guidance?

    Thanks very much.

  23. josephfritz
    Member
    Posted 4 years ago #

    I just had a similar issue with Permalink in WordPress while running locally in Snow Leopard and I finally resolved it after a few hours of messing around. I wrote about how I did it here: http://blog.xmog.com/wordpress-permalinks-404-when-running-in-os-x/

  24. levani01
    Member
    Posted 4 years ago #

    Having the same problem problem on WordPress 2.9.1 on linux VPS hosting. Any ideas?

  25. levani01
    Member
    Posted 4 years ago #

    I found a solution to this problem. mod_rewrite should be enabled in apache configuration but that isn't enough if php and apache are install separately

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride None

    should be changed with:

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    and don't forget to restart apache!

  26. oznola
    Member
    Posted 4 years ago #

    @levani01, what file are you proposing these changes to?

    i am observing the same problem reported by many in this thread using wordpress 2.9.2 on debian linux with apache 2.

    my httpd.conf is empty.

    @maxsidman, the .conf files are usually under /etc in linux.

  27. oznola
    Member
    Posted 4 years ago #

    for debian linux /etc/apache2/apache2.conf is used instead of httpd.conf.

    i added...

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    to the end of apache2.conf but when i tried to restart i got the error...

    bubba:/etc/apache2# apache2ctl restart
    Syntax error on line 287 of /etc/apache2/apache2.conf:
    AllowOverride not allowed here

    the only instance of AllowOverride is "AllowOverride None" in my apache2.conf and it is commented out. i suspect AllowOverride All is default.

    the .htaccess file seems to be updated okay by wordpress when i change the permalink settings from default to custom. mod_rewrite is enabled by default. subsequently i am led to believe that the problem is not with .conf files or configuration of apache2 but with the back-end of wordpress.

    please advise.

  28. flip983
    Member
    Posted 4 years ago #

    thanks to this topic, I am finally past my Permalink issues.

    Thanks Everyone!

    sudo nano /etc/httpd/conf/httpd.conf
    
    ctrl+w and find AllowOverrirde
    
    If it is not enclosed in a <directory> tag, change it from None to All
    Change any in relevant VirtualHost directories as well

    CentOS 5.4

  29. test.lamp
    Member
    Posted 4 years ago #

    hi mate(s),
    permalinks not working in local?

    just follow the two steps,
    Open your httpd.conf configuration file [that is in C:\xampp\apache\conf\]

    1. remove # from #LoadModule rewrite_module modules/mod_rewrite.so [line number 118]

    2. change AllowOverride None to AllowOverride All [line number 188]

    and restart Apache web server once [C:\xampp - double click xampp_restart.exe] or else just restart your system

  30. der.nichtschwimmer
    Member
    Posted 4 years ago #

    Apache won't allow setting AllowOverride All/Off in /etc/apache2/apache.conf, if you dont include it in <directory> and AllowOverride doesn't have to to be globally enabled!

    according to my experience the best way to solve the problem on ubuntu (and there for on Linux !?) systems is to define the permission in

    /etc/apache2/sites-available/yoursite

    Within the document you will find this:
    Docuementroot /path/to/yoursitedirectory/htdocs/

    change the following <directory> Tag to this:

    <directory /path/to/yoursitedirectory>
        Options Indexes FollowSymLinks Multiviews
        AllowOverride None
        Order deny,allow
        allow from all
    </Directory>

    Xampp users change the AllowOverride in there Apache conf.

    Hope this helps you!

    Cheers Matthias

Topic Closed

This topic has been closed to new replies.

About this Topic