WordPress.org

Ready to get started?Download WordPress

Forums

Permalink 404 Errors After 3.4.1 Install (9 posts)

  1. brithulsizer
    Member
    Posted 2 years ago #

    Since I installed WordPress 3.4.1, all pages, except my home page, are returning 404 errors UNLESS I have my permalinks set to default. I want them set to "post name."

    I have read a few other forums on this issue, but none of them seem to resolve my issue. My .htaccess file appears correct. It reads:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    I also deactivated all plugins, and the issue was still present.

    Any help would be much appreciated!

  2. dawebz
    Member
    Posted 2 years ago #

    I am having the same problem, except in my situation, I can't make a .htaccess ( yahoo hosting -_- ) however, another wordpress I have running on Yahoo! servers does NOT have this problem :(
    I have searched the interwebs and found no solution. I am on the same boat as brithulsizer.

  3. xposed100
    Member
    Posted 2 years ago #

    Hi,

    I had the same problem and this is what fixed it for me ...

    Please note my web server is appache

    1) Open the httpd.conf file in the apache conf directory
    2) Search for the following

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride None

    3) Replace the 'AllowOverride None' with 'AllowOverride All'

    Hope this works for you

    Thanks
    J

  4. brithulsizer
    Member
    Posted 2 years ago #

    Thank you, xposed100! Unfortunately, I use GoDaddy, and from what I can tell, am not given access to the httpd.conf file. Do you know if there is something I could add to the .htaccess file that would essentially do the same thing?

    Thank you!

  5. xposed100
    Member
    Posted 2 years ago #

    The config in your htaccess file (above) looks fine, its exactly what I have in mine, although im not an expert and cannot suggest anything else. Have you contacted GoDaddy to see what they say?

    Sorry i cant be more help!

  6. xposed100
    Member
    Posted 2 years ago #

    I have just experienced the exact same issue with another site.

    Weirdly it seemed to fix itself after i set it back to default, saved it and then switched it back to the permalink i wanted.

    I have no idea why this would matter! Can you try this if you have already done so.

  7. xposed100
    Member
    Posted 2 years ago #

    Apparently when its changed it recreates the .htaccess configuring the content to be relative to the site.

  8. Resaving your permalinks flushes the info in your database. So yes, do try pressing the save button on the permalinks page. You don't even have to change anything.

    (The .htaccess is fine, you can leave it alone. And if you're on GoDaddy, your httpd.conf is fine)

  9. brithulsizer
    Member
    Posted 2 years ago #

    Yes, I have tried setting to default, saving, and then setting to the post name and saving, but it does not fix it. I just can't figure it out, and my theme support tells me it's a WordPress issue.

Topic Closed

This topic has been closed to new replies.

About this Topic