WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink - 404 Error (8 posts)

  1. eaglenick
    Member
    Posted 6 years ago #

    I am sure this is something that has been asked many times before, and I tried finding a solution but I simply cannot.

    I have made one post so far on my new WordPress installation.

    I went to the settings and changed the Permalink structure from the default to one of the other presets.
    None of them work.

    When I click the post title from my blog homepage, I get a 404 Error.

    Error 404
    The post or page you requested can not be found on this site.

    Visit the Home Page or browse through the Archives.

    This happens if I use a custom permalink structure or any of the other preset ones.

    I would like to use a custom structure of /%category%/%postname%

    How can I fix this issue with permalinks?
    Thanks!

  2. Chris_K
    Member
    Posted 6 years ago #

    There are some troubleshooting tips at the Permalinks page in the docs section.

    For starters:
    After you change your permalinks, look at the bottom of that page. Any mention of a need to manually update the .htaccess file? If not, go check the .htaccess in the root of your WordPress install. Is it getting updated?

    And I guess first things first: Are you on an apache or IIS (windows) server?

  3. eaglenick
    Member
    Posted 6 years ago #

    I read that document and it's a bit confusing, considering I'm certainly no expert on web hosting, servers, etc.
    I can do basic, general things.

    I am on an apache server.

    When I change the permalink structure, an error message or anything does not show up on the bottom of any page.

    As far as I can tell, the .htaccess file is NOT being updated.
    In my FTP Client (Filezilla) it says it was last updated on 8/2/08 at 7:04pm. The current date/time is 8/3/08 10:23am.
    And the file is writeable (chmod 666)

    So what do I do next?

    Thanks for your help ;-)

  4. Chris_K
    Member
    Posted 6 years ago #

    Well, keep in mind server time may be a different time zone than you.

    What's in that .htaccess file that's currently there?

  5. eaglenick
    Member
    Posted 6 years ago #

    In the past, anytime I update a file via FTP, it will change to my current time.
    I know for a fact that my server is on the exact same time as me.

    Anyways, this is what's in the .htaccess file:

    Options +FollowSymLinks
    RewriteEngine On

  6. Chris_K
    Member
    Posted 6 years ago #

    Hmm, yep. WP isn't updating it.

    Try temporarily renaming .htaccess (perhaps to old.htaccess) and then visit Settings -> Permalinks again. Change to anything besides "Default" and see if an .htaccess is then created.

    If it is, just add the contents from old.htaccess to the top of the new .htaccess.

    It is isn't created, WP should tell you what to manually add at the bottom of the Permalinks page.

  7. eaglenick
    Member
    Posted 6 years ago #

    I did what you said and it didn't automatically create another one.

    And It isn't giving me any new/different text at the bottom of the Permalinks page.

    Does this have anything to do with my WP installation being in the root of my domain rather than in a sub-folder?
    I doubt it but I thought I'd mention it.

    Is there anywhere I can go to find out what to add to the .htaccess file?

    Thanks.

  8. eaglenick
    Member
    Posted 6 years ago #

    I found this thread: http://wordpress.org/support/topic/189058?replies=1
    And I did what it said in #2:

    on the Settings->Permalinks screen, add some values in for the category and tag bases. The words "category" and "tag" will do just fine. As long as they are not blank, this should work around the bug.

    and now it works. I am so glad.

    Thanks for your support. Too bad I didn't find that topic earlier. LOL

Topic Closed

This topic has been closed to new replies.

About this Topic