WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink 404 Error (3 posts)

  1. siege911
    Member
    Posted 6 years ago #

    I just did a fresh install of WordPress 2.6. I installed a few basic plugins and then changed my permalinks. Now I'm getting a 404 error.

    I'm hosting the site on my works webserver. I noticed that we didn't have mod_rewrite enabled, so I went ahead and enabled it. It still didn't fix the problem. I've tried all sorts of changes to the .htaccess file but nothing works. I even did what it said in the Permalink Sticky thread.

    Here is how my .htaccess currently looks:

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    What did I miss? My Google-Fu hasn't given me anything. It's just the same solutions regurgitated all over but they don't fix it.

  2. siege911
    Member
    Posted 6 years ago #

    Alright, after more and more searching, I did find something that fixed it. I needed to change "Allow Override None" to "Allow Override All" in my Virtual Host settings.

  3. enrico_34
    Member
    Posted 6 years ago #

    Yep, the server didn't allow that obviously...

Topic Closed

This topic has been closed to new replies.

About this Topic