WordPress.org

Ready to get started?Download WordPress

Forums

Perma Links Problem (3 posts)

  1. ghpink
    Member
    Posted 2 years ago #

    When I use the Perma Links option in the settings (i have installed a custom theme) the perma links will now go to pages with really good linkage, but it says... Not found...

    I created new pages after I installed perma links and still when clicking to the new pages, it says not found.

    I have had this trouble before, and as soon as I turn perma links back to default "i then get pages like this" http://www.nickthepromisering.com/?p=1" - but they don't have descriptive URLS...

    I was wondering if anyone else had this problem and how i fix it?

  2. rmfn8475
    Member
    Posted 2 years ago #

    Go to permalinks in settings... select custom, then add --> /%postname%

    then in you theme folder either modify or create the .htaccess folder within your theme root .. enter below

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    save.. then refresh your browser.. you shouldnt have any more 404 errors.

  3. ghpink
    Member
    Posted 2 years ago #

    I turned on permalinks, went to custom and added
    "/%postname%

    Then added the .htaccess to the root of my theme folder, and its not working.

    You said create .htaccess folder, but did you mean file? I created a file in the root of my theme folder called .htaccess

    What am I doing wrong?

Topic Closed

This topic has been closed to new replies.

About this Topic