WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
Performance-Problem with the calendar (34 posts)

  1. Simpson199
    Member
    Posted 4 months ago #

    Hi!

    Cool Calendar, would like to buy it, but...

    On trying to make my website faster I use caching tools and - more importat, analyse what happens.

    Some of the All In One Event Calendar Scripts really slows down my site (for 4 Seconds plus!):

    One of those files, what is it and how can I get rid of it:

    domaine.de/?ai1ec_render_css=12345&ver=3.8.1

    So how can I get it on to work with for example a minify-tool like bp minify, autoptimizer and wp super cache or w3 total cache??

    Thanx for helping me...

    Simps

    https://wordpress.org/plugins/all-in-one-event-calendar/

  2. Jashan
    Member
    Plugin Author

    Posted 4 months ago #

    Hello,

    Our next version will fix this :)
    We have built the version2.0 mainly to fix the issues with performance and load times.
    V2.0 is coming out next week.

    Take Care

  3. Simpson199
    Member
    Posted 4 months ago #

    Hi!

    I read that 2.0 comes last Oktober) ;-)

    Sorry...

    Simps

  4. Endymion00
    Member
    Posted 4 months ago #

    While you wait for 2.0, you can try the following if you're done setting your css.

    copy the css text content from domaine.de/?ai1ec_render_css.....

    create a file at:

    /wp-content/uploads/calendar.css

    and paste the css text in that file.

    Edit the .htaccess file at the root of your site:

    Add:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    
    RewriteCond %{QUERY_STRING} ai1ec_render_css
    RewriteRule ^(.*)$ /wp-content/uploads/calendar.css? [R=301,NC,L]
    </IfModule>

    If your site supports mod_rewrite like most should, then this will redirect the css request to the static calendar.css file instead, which should alleviate the load time caused there.

  5. Simpson199
    Member
    Posted 4 months ago #

    Thanx, so I tried 1 hour and it doesn't work :-(

    Now I go and use another calendar. The Problem slows the page down.

    Sorry, greets

    Simps.

  6. Endymion00
    Member
    Posted 4 months ago #

    Note that my suggested adjustment only affects the css loading. If you use the calendar in a sidebar on every page, then there's other files loaded that can still slow down the site, especially when viewing the site uncached while logged in as an admin. Removing the css hit removed about 3-4 seconds from some page loads for me.

  7. Simpson199
    Member
    Posted 4 months ago #

    The Problem here is that they tell the people about version 2.0 since a long time, nothing happens.

    The Calender Css is the only style-sheet that takes 3 oder 4 seconds. It's because they wrote it in a manner thats not to cache. so there is no problem when they would programmit good and make update.

    Bute nothing happens, there is no trust in that calendar-team any more, sorry.

    Simps.

  8. Jashan
    Member
    Plugin Author

    Posted 4 months ago #

    Hello Lauren,

    Public Beta for 2.0 is available:http://community.time.ly/forum/all-in-one-event-calendar_aa/-2-0-core-public-beta-rc1-now-available/10101-2-0-core-public-beta-rc1-now-available
    Performance and load times are a huge focus as we work to build v2.0

    In most of the cases, the reason of this high memory usage is GOOGLE CRAWLING. Please read our article here on how to limit Google crawling: support.time.ly/limiting-excessive-google-crawls/

    Please clear your cache periodically from Wp-content -> plugins-> All in one calendar -> Cache

    Take care

  9. itsmir
    Member
    Posted 4 months ago #

    Thank you, thank you, thank you Endymion00 for the redirect rule, using it in conjunction with wp supercache the site I'm building is flying again. Load times down from 7-8 seconds to 480ms which makes me and my client very happy.

  10. cerulean
    Member
    Posted 4 months ago #

    Any update on when 2.0 is really coming out? Thanks for your work on a faster calendar.

  11. crsouser
    Member
    Posted 4 months ago #

    I will also chime in that the Endymion00 fix was helpful as well.

    I would be curious about what the other action is to speed up the load of the "?ai1ec_render_js=common_frontend&is_backend=false&is_calendar_page&ver=1.11.4-pro" would be and when you open it open it is JAVA Script and it is about 2.5 to 3 seconds average (30%+ of my load time)

    Looking forward to 2.0; but a little hesitant after issues right now I'm already fighting with W3-Total Cache and CloudFlare with the calendar.. so waiting for a more stable version.

    (I.e. When I use CloudFlare the SuperWidget doesn't work at all and W3-Total Cache seems to be causing the single A1EC short code to display twice on page with different list of events information; even after the caches have been purged and CloudFlare disabled.).

  12. itsmir
    Member
    Posted 4 months ago #

    Looking forward to 2.0; but a little hesitant...

    As my client is now happy with performance and the tweaks to prevent it using so much php memory are doing their job I've recommended that we not update the plug-in until they are 'out-of-season' and the calendar functionality is not so important. Hopefully by then any further bugs and/or issues will have been addressed either by the author or on the forums.

    I'm using WP SuperCache and so far it's playing nicely!

  13. Endymion00
    Member
    Posted 4 months ago #

    Good to hear that my fix is helping some. The speediest is to use the fix and not use a sidebar calendar on every page, leaving it to just appear on a calendar page. Then barring any other plugin slowdowns, your site should be nice and quick.

    I had a client whose site is on one of those shared hosting sites and after a recent update to the calendar plugin, they started having their site shutdown due to high resource usage.... so the above was my fix to get them running and not keep getting shutdown.

  14. Endymion00
    Member
    Posted 4 months ago #

    crsouser,

    You could try making the js file static as well, but I'm not sure if any unique changes occur in that file causing it to need to be dynamic or not.

    copy the js text content from /?ai1ec_render_js.....

    create a file at:

    /wp-content/uploads/calendar.js

    and paste the js text in that file.

    Edit the .htaccess file at the root of your site:

    Revise it to:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    
    RewriteCond %{QUERY_STRING} ai1ec_render_css
    RewriteRule ^(.*)$ /wp-content/uploads/calendar.css? [R=301,NC,L]
    
    RewriteCond %{QUERY_STRING} ai1ec_render_js
    RewriteRule ^(.*)$ /wp-content/uploads/calendar.js? [R=301,NC,L]
    </IfModule>

    Again, be prepared to reverse that if it causes any issues.

  15. Jashan
    Member
    Plugin Author

    Posted 3 months ago #

    Hello Endymion00,

    Thank you for your solution. I am glad it is helping some other users.

    Thanks

  16. jeanrapidshare
    Member
    Posted 3 months ago #

    Hi Endymion00,

    I first implemented your CSS trick: page load time fell from 8.21 sec down to and incredible 0.799 sec !
    As for the functionality of the calendar, look and feel remained perfect, with a minor concern though: calendars do not display "event@venue" any longer, only "event" (not a big deal to me).

    I then made the js file static: no significant change was noted.
    So I will stick to the css static file trick.

    Thanks a lot for this, I was about to go for another calendar system.

  17. cerulean
    Member
    Posted 3 months ago #

    This fix does make a large performance improvement.

    However, something I've noticed is when it is in place, the backend of the calendar seems less functional. The calendar date pickers no longer pop up and it's not possible to open the accordions to add location and so on. Looking forward to the new version which hopefully will be stable sooner rather than later.

  18. Lucas Karpiuk
    Member
    Posted 3 months ago #

    Just another +1 to thank Endymion00 for his fix for this. I've not noticed the backend functionality loss described by cerulean - but we've only implemented the rewrite for the CSS, not the JS, which I assume is the reason.

  19. Endymion00
    Member
    Posted 3 months ago #

    Yeah, like mentioned, since I hadn't done the js one myself, I wasn't sure what negative effect it would have. Just using the css without a sidebar calendar makes the majority of the site load quick and only a 3 second or so delay on the calendar page itself due to the js and other content.

  20. cerulean
    Member
    Posted 3 months ago #

    Thanks for the clarification on the JS and the fantastic solution

  21. martyrkanin
    Member
    Posted 3 months ago #

    Endymion00, I'm anxious to try your CSS redirect trick -- this plugin is causing my site to move like molasses -- but I don't know where to find this:

    copy the css text content from domaine.de/?ai1ec_render_css.....

    I've FTPed into my site and looked through every single subfolder under this plugin. I can't find anything even remotely like what you mention here. Where is this file located? Thanks so much; I really appreciate it!

  22. jeanrapidshare
    Member
    Posted 3 months ago #

    @martyrkanin,

    No wonder, the file does not exist as such in plugin folder, it is generated by the script.

    Open the webpage containing your calendar, right click anywhere and select "View page source".
    Then search for "ai1ec_render_css" (without the quotes).
    Once you've found the link, click on it, it will open the css file in question.

    Select all and paste it into calendar.css, then follow the tutorial by Endymion00.

    Cheers,
    Jean

  23. cerulean
    Member
    Posted 3 months ago #

  24. martyrkanin
    Member
    Posted 3 months ago #

    Got it! Thanks for elaborating, jeanrapidshare. I've got the CSS content copied into a calendar.css file per Endymion00's directions.

    My next problem is that I can't find this file either:

    Edit the .htaccess file at the root of your site:

    I've FTPed to my site and am looking at the files under [mydomainname].com. I don't see anything that says .htaccess. Is it possible that this file either does not exist or that it might be located elsewhere? Sorry for so many questions, but I very much appreciate the help. This 1.10.11 version of the plugin is killing my site.

  25. cerulean
    Member
    Posted 3 months ago #

    It's possible you might not see an .htaccess file because it's a hidden file type. Someone else might have better info or you might contact your host about the location. Here's some WP info on .htaccess: https://codex.wordpress.org/htaccess

  26. Endymion00
    Member
    Posted 3 months ago #

    Some FTP servers may be configure to hide the dot (.htaccess) files. You could try a htaccess editing plugin:

    http://wordpress.org/plugins/wp-htaccess-editor/

  27. jeanrapidshare
    Member
    Posted 3 months ago #

    @martyrkanin

    As cerulean says, the dot before the file name indicates that it is a hidden file. When you are accessing your web server through FTP, you might not be able to see it unless your FTP client is forced to show hidden files.

    Sometimes - and even when you have forced your FTP client to show hidden files - it might still not show the file. The most common reason for this is that your WordPress site has not generated a .htaccess file yet.

    WordPress generates .htaccess file for the first time when you set up pretty permalinks on Settings --> Permalinks screen. All you need to do is to change the settings and click on Save Changes button on the permalinks screen. WordPress will generate a .htaccess file in your site’s root directory.

    You might opt for URL Structure "/%category%/%postname%/".

    Hope this help.

  28. martyrkanin
    Member
    Posted 3 months ago #

    Thanks, guys, I switched to FileZilla and was able to see the hidden file. Unfortunately after I made the changes described, P3 Plugin Profiler reported that the calendar plugin was actually slowing the site down MORE, so I guess it's back to the drawing board. Thanks anyway for your help, though!

  29. Endymion00
    Member
    Posted 3 months ago #

    This fix would have no effect on what P3 plugin profiler would show. It's more about how quickly your page loads when you're not logged in like the general public and assuming you're using a caching plugin like WP Super Cache or W3 Total Cache.

  30. cerulean
    Member
    Posted 3 months ago #

    @martyrkanin you might try something like this: http://tools.pingdom.com/fpt/
    (note that the location you choose makes a difference in speed)

Reply »

You must log in to post.

About this Plugin

About this Topic