WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks troubleshooting (5 posts)

  1. sweetchili
    Member
    Posted 5 years ago #

    I can't get the permalinks to work. I have upgraded to the latest version 2.6.1 and tried different themes, nothing works; either a 404 error is displayed, or the main page is permanently displayed. Thanks.

  2. iridiax
    Member
    Posted 5 years ago #

    Here's more info: Using "Pretty" permalinks

    If your server uses IIS, then check out: Permalinks without mod_rewrite

  3. Joni
    Member
    Posted 5 years ago #

    You do have an .htaccess file in your WP root, correct? CHMOD it to 666, THEN turn on permalinks, and THEN after WP updates the permalink structure, CHMOD it back to 644.

  4. sweetchili
    Member
    Posted 5 years ago #

    Where do I find the CHMOD setting? If it should be in the .htaccess file, something went wrong. The file is the following with permalinks enabled:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Thanks.

  5. sweetchili
    Member
    Posted 5 years ago #

    Okay, I found the CHMOD function, but FTP is not allowing me to change this? How can I do this?

Topic Closed

This topic has been closed to new replies.

About this Topic