WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] pdf upload error (15 posts)

  1. volutedtales
    Member
    Posted 4 years ago #

    Hi all!
    First time here. Hosting new intall of wpmu 2.9.2 and buddypress with TMD Hosting (and intending to add s2Member soon) and slowly making sense of it as I play with features. I'm an online 'zine editor/publisher, so need to upload sizeable pdf's, but my test of this with a pdf of just over 13MB results in the system spinning its wheels with a 'crunching' message that never ends, and an 'HTTP Error' message.
    Other image files loading just fine, only the pdf having problems.
    The dashboard tells me that I still have a 10MB space limit, but the hosting service has unlimited space. Could the problem lie with something there that I need to change, so that wpmu will accept the larger files instead of thinking that it exceeds its space limit? That's the only possibility I can think of.

    Any tips? Plain-speak please, I'm self-taught, not great at tech-speak :)

    Thanks, Mark.

  2. The dashboard upload limits is on a site0-by-site basis, so if you want more (regardless of how much your host has) you need to raise it within WP.

    See, if your host has 1,000 MB and you have ten sites with 100 MB apiece, that uses it all up, in theory. ;)

    Go to the Super Admin menu and find the list of Sites. hover over the site you want and an "edit" link shoudl appear underneath. Click it! :D

    On this new page of a whole pile of things, there's a section on the... right column? mentioning upload space.Crank it up to whatever you like.

    I host a blog for my mom and I have her upload space set to 500 Megs because she thinks I'm her own personal Flickr. ;)

  3. volutedtales
    Member
    Posted 4 years ago #

    Hi Andrea,

    Thanks for that, but I can't find any Super Admin menu anywhere :(

    I have only one site, not a list of them, so is this something I need to activate somewhere or somehow before it'll appear to offer access?

    I've been hunting around everywhere else I can try, but can find no other way to adjust the limits anywhere, so this sounds like it may be the only way. Just need to make it active so that it shows somewhere?

    How do I find or activate this Super Admin please?
    Thanks, Mark.

  4. pizza boy
    Member
    Posted 4 years ago #

    My question would be, why would you want to upload and download a file that large? If you are selling ebooks or whatever, why not zip the pdf and take stress off your server and customers Download time.
    If you are unfamiliar with zipping a pdf you can follow these steps.
    zip pdf

    Or you can also FTP the file to its folder on you server in full size if you wish as a work around for upload limits

  5. volutedtales
    Member
    Posted 4 years ago #

    Hi Pizza boy, thanks for that.

    The idea with the site tho' is not just to offer a digital download of the pdf, but to place the entire magazine on site to be read online, so I was looking to simply upload it to a page so members can read it.

    Is there a better way to do this, are my amateur skills showing :)

    I've also no idea what 'FTP the file to its folder' entails, or means :(

    I'd still like to find and try this Super Admin function to see if it works, if anyone can steer me to it. Everything's worth a try.

    Thanks, Mark.

  6. pizza boy
    Member
    Posted 4 years ago #

    If it were me I would be uploading those to google docs and allowing your members access to them. This helps in a number of ways, 1- helps build authority for your site 2- takes the stress off your server 3- builds quality back links to you ;)

  7. volutedtales
    Member
    Posted 4 years ago #

    Thanks, I'll look into that :)

    Meantime, any tips from anyone on getting the Super Admin access as well, just to see for myself what it's all about, would be very welcome!

    Thanks again :)

  8. pizza boy
    Member
    Posted 4 years ago #

    if you have access to your wp-admin and you are the installer (owner) you are already super admin ;)

  9. pizza boy
    Member
    Posted 4 years ago #

    In admin under settings / Miscellaneous

    wp-admin/options-misc.php

    you can set directories for uploads. As far as size limits you will need to look server side or cpanel with your host. I would imagine they have it limited. If you can not increase on the server yourself you will need to contact them.

  10. volutedtales
    Member
    Posted 4 years ago #

    Thanks Pizza boy, I appreciate your time!

    I've hunted, but the 'miscellaneous' just doesn't exist on my admin anywhere. Yeah, I'm bamboozled too.

    I've opened every other tab available to me, and there's nothing helpful.

    The only 'settings' tab is under 'appearance'.

    Under the 'site admin' box on the left of the dashboard page there is no 'misc', only blogs users themes options global terms & upgrade.

    Are we talking about the same page, or is there something missing from my install?
    It was done the the hosting service, so I assume it to be done right, better than I could do anyway :)

  11. pizza boy
    Member
    Posted 4 years ago #

    First what version of wordpress did they install?
    upgrade to version 2.9.2 then you should see more functions in admin

  12. volutedtales
    Member
    Posted 4 years ago #

    That is the version, wordpress mu 2.9.2

    Do you think it'd help if I ask them do wipe it an try a reinstall? It's sounding to me like something's wrong with this one.

  13. pizza boy
    Member
    Posted 4 years ago #

    You can do that yourself by going to tools and upgrade and click reinstall. Just make sure you have everything you need backed up as it will erase it all ;)

  14. volutedtales
    Member
    Posted 4 years ago #

    Solution!

    Just dropping back for anyone reading to share what I've learned.

    It seems that the features available under 'admin' differ between wordpress single-user and MU.

    The 'miscellaneous' tab is only on the single-user version.

    Users of MU need to go to admin>blogs, then place the mouse over the blogs to display the small print links below the domain/blog name. Click 'edit' there and it opens up the settings page that's needed. This has to be done on a blog by blog basis, hence the difference. With the single user, there's just the one blog, so it's accessed directly from admin in the dashboard, but MU has multiple blogs, hence each one must accessed individually from the blogs page, and each have its own storage space limit adjusted.

    The guys at my hosting service solved the problem for me, and I hope it's of help to anyone else who's a newcomer to MU too. As a result, I now understand how this MU software actually works, at last :)

    Thanks Pizza Boy and Andrea, much appreciated!
    Mark.

  15. greenroofsolutions
    Member
    Posted 3 years ago #

    Hi Everyone
    I'm now in a similar boat, but have managed to move all my docs via ftp into the wp-content/uploads/2010/08 folder--and WordPress doesn't seem to recognize that they are there when I try to access via the gallery. I'm not a strong coder, so I do what I can and appreciate any help. Thanks. Catherine

Topic Closed

This topic has been closed to new replies.

About this Topic