WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
Paypal not finding ship to address (6 posts)

  1. Beepmode
    Member
    Posted 8 months ago #

    Store URL: http://www.galleybeggar.co.uk/book-store/
    WordPress version: 3.8
    WP e-Commerce version: 3.8.13.1
    Gold Cart version: N/A
    Theme: Custom

    I did this:
    Tick the 'shipping address is same as billing address' box.

    I expected WP e-Commerce to do this:
    Send the shipping address details to Paypal.

    Instead it did this:
    Caused Paypal to give this error:

    Unable to process payment. Please contact the merchant as the postal address provided by the merchant is invalid, and the merchant has requested that your order must be delivered to that address.

    Further details:
    The error occured after upgrading WP to 3.8 and WP e-Commerce to 3.8.13.1. The message only appeared when the above-mentioned box was ticked - people could still buy items by manually entering a shipping address.

    The error doesn't appear when I comment out lines 145 to 148 in /wp-content/plugins/wp-e-commerce/wpsc-merchants/paypal-standard.merchant.php, like so:

    if ( (bool) get_option( 'paypal_ship' ) && ! $buy_now ) {
      //  $paypal_vars += array(
      //    'address_override' => '1',
      //    'no_shipping' => '0',
      //  );

    Everything is working now but I'm hoping someone is able to explain what triggers the error and to provide a better solution. I'm not sure what exactly the 'address_override' and 'no_shipping' variables do when set to 1 and 0, respectively.

    I should mention that, after the upgrades, I also installed the 'Members Only: Membership & Subscription plugin for WP e-Commerce' plugin (version 2.9). The site's error log showed the following entry at the time the error appeared:

    galleybeggar.co.uk [Mon Dec 30 11:35:13 2013] [crit] [client 22.211.115:41124] AH00529: /home/sites/galleybeggar.co.uk/public_html/wp-content/plugins/wpec-members-nnnnnnnnnnnn/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/home/sites/galleybeggar.co.uk/public_html/wp-content/plugins/wpec-members-nnnnnnnnnnnn/' is executable

    After commenting out the four lines in paypal-standard.merchant.php the error no longer comes up, so it seems the error may have something to do with the plugin.

    http://wordpress.org/plugins/wp-e-commerce/

  2. karlcw
    Member
    Posted 7 months ago #

    I'm having the same problem, and mine is just a simple install with no membership plugins etc.

    Please help WPEC experts!!!

  3. karlcw
    Member
    Posted 6 months ago #

    OK, tried the fix above and it crashed the site with this message:

    Parse error: syntax error, unexpected T_VARIABLE, expecting T_FUNCTION in /home3/karlcw/public_html/helensvintagecafeandcraft.co.uk/wp-content/plugins/wp-e-commerce/wpsc-merchants/paypal-standard.merchant.php on line 168

    I put the lines of code back in and still get the same message.

    Come on guys, let's sort this please.

  4. karlcw
    Member
    Posted 6 months ago #

    I reinstalled WPEC to make sure I had all the latest files etc and the problem still hasn't gone away.

  5. karlcw
    Member
    Posted 6 months ago #

    OK, after a bit of tinkering I thing I worked out how to resolve this (sort of).

    I change the Store > Payments > Send shipping details to 'No'.

    This it doesn't try sending this info to Paypal and I now get no error.

    Having thought about this, I'm not sure why you'd want to send shipping details to Paypal anyway???

  6. Beepmode
    Member
    Posted 6 months ago #

    I change the Store > Payments > Send shipping details to 'No'.

    Doesn't that mean buyers are likely to enter the shipping address twice (on the checkout page and on the Paypal site)? When I change this setting the checkout on my web site still shows a form with a ship to address.

    I just upgraded WP to version 3.8.1 and the e-commerce plugin
    to version 3.8.13.3. I got the same error message again, and commenting out the four lines of code still works for me.

Reply

You must log in to post.

About this Plugin

About this Topic