WordPress.org

Ready to get started?Download WordPress

Forums

Paid Memberships Pro
[resolved] Payments don't work at all (8 posts)

  1. eddie_olivas
    Member
    Posted 1 year ago #

    I'm using PMPRO 1.5.9 and WordPress 3.5. We have Paypal Standard setup, but no matter what payments don't seem to be communicated back to the plugin that they have gone through. The Paypal payments go through, but the user is simply set to no membership level on the website. They are only set as a subscriber in WordPress with no level and no payments get communicated back to the site that they've gone through.

    When I try to access the confirmation page it always redirects back to the home page of the site. This is the site I'm referring to:

    http://janbella.com

    I have setup a Paypal sandbox account and everything happens exactly the same. Payments on Paypal work on that end, but don't get communicated to my website and no payment information is received by the plugin. I have setup the IPN handler on Paypal. Is there something we're missing? Any assistance you can provide would be appreciated.

    http://wordpress.org/extend/plugins/paid-memberships-pro/

  2. eddie_olivas
    Member
    Posted 1 year ago #

    I was able to resolve this issue by creating new membership levels. For some reason after upgrading to WordPress 3.5 all of the existing membership levels were broken and the membership confirmation page would only redirect to the home page for those levels.

    When I created new levels and went through the payment process for those everything works perfectly. Just deleted the old membership levels, created new ones, and re-assigned everyone to the new levels.

    Hopefully this is helpful to someone.

  3. strangerstudios
    Member
    Plugin Author

    Posted 1 year ago #

    Hey guys. I'm actively working to fix things with PayPal Standard. Stay tuned this weekend for update 1.6 to fix it. Sorry for the trouble.

  4. itsrye
    Member
    Posted 1 year ago #

    I just updated the plugin to the most current version and now my Standard payments are working correctly with the IPN. Thanks!

  5. developingtheweb
    Member
    Posted 1 year ago #

    I am having issues regarding this, ipn seems to communicate from my sandbox account correctly but the plugin doesn't assign the membership payment level to the new user.

  6. developingtheweb
    Member
    Posted 1 year ago #

    Looks like the plugin isnt sending the membership account id along with the payment correctly as although the payment seems to go through the membership field is also blank in the merchant confirmation email.

  7. mnaeem
    Member
    Posted 1 year ago #

    Hi,
    I have configure Authorize.net (With Testing mode active) account with plug-in. Due to this setting it gives SSL error on demo server. Can we disabled SSL with Authorize.net account setting?

  8. strangerstudios
    Member
    Plugin Author

    Posted 1 year ago #

    mnaeem, using this code will deactivate the SSL redirect. (You should have started a new thread for a new issue.)

    add_filter('pmpro_besecure', '__return_false');

    RE the PayPal issues, if you are running the latest version and still having issues, please post a new thread with as much information as you can about your setup, which PayPal option, you membership levels, etc. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic