WordPress.org

Ready to get started?Download WordPress

Forums

WP Original Media Path
[resolved] Paths NOT changing in "Media" (8 posts)

  1. morespinach
    Member
    Posted 10 months ago #

    Installed it. The files are uploading in the right place (custom path). Yet, the "full media URL" is not being honored.

    I have a CDN setup, so:

    (1) I upload into the folder "/wp-content/cdn" --> This works

    (2) The URLs to this folder do NOT need to be domain.com/wp/wp-content/cdn/.., but instead, need to be a custom static subdomain, cdn.domain.com. Despite specifying this in the settings, my paths still show up as the long URL.

    Any ideas on how to fix?

    Thanks!

    http://wordpress.org/plugins/wp-original-media-path/

  2. RVOLA
    Member
    Plugin Author

    Posted 10 months ago #

    Hello @morespinach
    the first field must contain:
    "wp-content/cdn"
    You cdn.domain.com point to the root of your WordPress site.
    The second field should contain:
    "http://cdn.domain.com/wp-content/cdn"

  3. morespinach
    Member
    Posted 10 months ago #

    Thanks. But second is not what I want. The cdn.domain.com is already mapped to wp-content/cdn. The usual 'origin pull'. Any ideas? Or is that not what this plugin does? (In which case I don't know what it does -- because getting the long URL already works with default wp!)

    Thanks

  4. RVOLA
    Member
    Plugin Author

    Posted 10 months ago #

    So if the second is mapped to the cdn folder, you just put in the second http://cdn.domain.com fields

  5. morespinach
    Member
    Posted 10 months ago #

    That's what it is now, and it doesn't work. (This is what I explained in my original post)

    In the media section, when I click on 'edit' on a file, the path is still the long path with 'wp-content/cdn'. Hence my confusion as to what this plugin actually does.

  6. RVOLA
    Member
    Plugin Author

    Posted 10 months ago #

    Hum ...

    I have a WebSite is configured as follows: the WordPress uploads folder has not been renamed and is located at its place of origin is: http://domain.com/wp-content/uploads

    I created a subdomain pointing to the uploads folder is: wp-content/uploads

    Then in the plugin I set like this:
    1st fields: empty
    2nd fields: http://cdn.domain.com

    Normally it should work.

  7. morespinach
    Member
    Posted 10 months ago #

    OK, it works now. It was MY mistake -- I had some old "UPLOAD_URL" etc settings in my wp-config.php, which I have now deleted. Now it works!

  8. RVOLA
    Member
    Plugin Author

    Posted 10 months ago #

    Yeah :)
    I pass in the topic solved.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.