WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] PATHINFO / Almost pretty permalinks do not work (5 posts)

  1. zaqedc
    Member
    Posted 2 years ago #

    I've got a website running locally on a machine using IIS 6 (same as the eventual host) and I can't even get "almost pretty" (format beginning with index.php) permalinks working. I've seen lots of threads and blog posts regarding getting pretty permalinks to work on IIS 6 but, as my host likely won't allow me enough access for custom 404 redirects or ASAPI_Rewrite-basaed solutions, those are no use to me. That's not really a problem as I don't mind having the almost pretty permalinks for the site.

    Unfortunately, when the structure is set, with index.php at the start, I get 404-ed whenever I navigate beyond the homepage. I've followed the instructions in the codex to the letter but the problem persists.

    I've searched around but haven't found anyone else with a similar problem. Anyone come accross this before?

  2. zaqedc
    Member
    Posted 2 years ago #

    Put a fresh copy of wordpress on the machine and started from scratch to see whether or not it was something specific to my tweaking of the site that caused the issue. Problem was the same with the fresh. Have now restored the old site. If anyone has any ideas I'd appreciate it.

  3. zaqedc
    Member
    Posted 2 years ago #

    Seeing what appears to be conflicting information regarding permalinks for IIS 6. From what I've been reading it appears that once this workaround is applied that it will allow "pretty" permalinks. But the result of this thread appears to suggest that such a fix must be applied in order for PATHINFO permalinks to work. Can anyone clarify? If so, I may have to speak to my host to see if it's possible to allow changes to the IIS.

    EDIT - I should mention also that, having applied the above fix, pretty permalinks will not work for me, just display a 404 if I click into a page beyond the static front page.

    Using PATHINFO permalinks works marginally better. When clicking on a page that's not the front one, it will load the wordpress 404.php template and loop through/display all the posts.

    So, more or less still in the same boat!

  4. zaqedc
    Member
    Posted 2 years ago #

    Tried deactivating all plugins and switching to twenty ten theme, on the off chance. Problem persists.

  5. zaqedc
    Member
    Posted 2 years ago #

    Marking as resolved - host will not allow iis settings changes so above is not necessary.

Topic Closed

This topic has been closed to new replies.

About this Topic