WordPress.org

Ready to get started?Download WordPress

Forums

[Theme: Path] Path showing as "site.com//wp-admin" (4 posts)

  1. Chris Rakoczy
    Member
    Posted 1 year ago #

    We just completed a migration of a multisite WP installation, and I found that the original developer built the site on "site.us" before transferring it to "site.com". Since then, uploaded content like pictures link to "site.us/wp-content/etc" even though the domain redirected to "site.com". I did a seach and replace throughout the database for all occurences of "site.us" and replaced them with "site.com", then went though the wp-config.php file and other files doing the same S&R. Everything seems to be good, except for some reason, now the main sites admin screens link to "site.com//wp-admin" with TWO forward slashes after the domain name. For the life of me, I cannot figure out where this came from. I didn't include any slash in any of my search and replaces, and I didn't add a slash to any of the blog settings or network settings or site url or anything. It seems to have just appeared.

    Also odd, only the main site exhibits this problem. The four other sub blogs a.site.com, b.site.com, etc all do NOT show the extra slash. FWIW, the main blog has a custom URL, and one of the sub blogs has a custom URL.

    Any thoughts / solutions?? It seems to interfere with being logged in as an admin, though for the most part, the site actually behaves normally, even though the public sees the extra slash, too.

  2. You probably accidentally put a slash in the URL when you were doing the search/replace. If the issue didn't show up until you did that, it's the most likely culprit.

    Go to /wp-admin/network/sites.php

    Click on 'edit' for your main site.

    It should show up with:

    Domain http://site.com
    Path /

    Is there an extra / after site.com?

  3. Chris Rakoczy
    Member
    Posted 1 year ago #

    It's nothing quite that obvious. I made very sure I did not plac an extra slash in my replace string, and I did not add an extra slash to the site settings URL.

    It shows up on certain links, but not all. For example, in the admin screens, the "Dashboard" link does not:
    http://example.com/wp-admin/

    While the "Visit Site" link does:
    http://example.com//

    And links to blog posts from the Posts screen do:
    http://example.com//featured/blog-post/

    While links to the same post in the Google Analytics Dashboard Widget do not:
    http://example.com/featured/blog-post/

  4. What plugins are you using?

Topic Closed

This topic has been closed to new replies.

About this Topic