WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Path for uploading files disappeared (9 posts)

  1. wp_europe
    Member
    Posted 1 year ago #

    Hello,

    I have a problem with section for defining path for uploading files. Firstly I had problems with uploading files, there was a message coming on: "Unable to create directory uploads/2013/05. Is its parent directory writable by the server<?"
    Then I googled the issue and found that I have to change the path of uploading files. I changed it and I guess I deleted / too much and now the section for choosing path for uploading files magically disappeared!
    Someone knows how to get it back? I have tried and searched through entire WP but found nothing.
    Did anyone had similar problem and how did you solved it?

    Thank you very much for help!

  2. govpatel
    Member
    Posted 1 year ago #

    Using ftp or your host panel check if you still have uploads folder in wp-content folder

  3. wp_europe
    Member
    Posted 1 year ago #

    I have checked and I dont have it... What now? Can I create another myself?

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  5. wp_europe
    Member
    Posted 1 year ago #

    Sorry but I don't understand how this will show again my uploads folder... Can you please explain it to me in more detailed way please because I am kind new with wordpress. Anyway I changed permissions to the wp-content directory but nothing happened...
    Thanks

  6. govpatel
    Member
    Posted 1 year ago #

    Esmi meant by changing permissions of wp-content folder and you try and upload anything the folders will be created. if wordpress does that you can change permissions of wp-content back to 755

  7. wp_europe
    Member
    Posted 1 year ago #

    I changed permissions as esmi wrote and then tried to upload an image but still nothing works.
    I also noticed that whenever I changed the permission in the ftp client it answered:"500 'SITE CHMOD 766 wp-content': command not understood". Could it be something wrong with ftp? Is there some other solution to this issue?

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you spoken to your hosts about this?

  9. wp_europe
    Member
    Posted 1 year ago #

    Solved the problem finally!:) I wrote to the host and they answered how to change the permissions of a directory in the hosting manager.
    Then I changed the permissions of wp-content directory and now it works. I also changed the permission of the directory back to 755.
    Just for the record, my ftp client still gaved me a message: "500 'SITE CHMOD 766 wp-content': command not understood" but it worked nontheless.

    Thank you esmi and govpatel!
    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Topic