WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Path and File have no / between them. (10 posts)

  1. solo013
    Member
    Posted 8 months ago #

    As said in the topic the gallery paths have no / between them or the file name. i.e. wpcontent/gallery/galleryname/file.exe becomes wpcontentgallerygallerynamefile.exe

    I had this issue in 2.00 and now in 2.07 as well. Rolling back to 1.9 fixed the issue both times. I searched everywhere I could think of and didn't see the issue as a topic or mentioned besides anyone but myself.

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 8 months ago #

    @solo013: We think we know, partially, what was causing this. In NextGEN 2.0.0 or 2.0.7, if you go to Gallery > Other Options > Image Options, you can set the path for where NG should upload files.

    The default setting is /wp-content/gallery/

    For some reason, for some users, the update cause the trailing / to drop off. You can fix this by just adding back the trailing / and re-uploading any images. Once that's adjusted, it should be set.

    Here's a screenshot of the relevant page in the options panel:
    http://owely.com/0uY2kT

    Let us know if you have other questions on this.

  3. solo013
    Member
    Posted 8 months ago #

    Tried the fix, but it didn't fix anything.

  4. photocrati
    Member
    Plugin Author

    Posted 8 months ago #

    @solo013: When you checked that setting, was the / missing? If so, I'm wondering if you can test whether NEW uploads are fine. The ones you uploaded while the / was missing may just have the wrong paths associated with them now.

    If you are still getting it with the new images, first, are you on a local Windows-based dev environment? If not, would you be willing to submit a bug report with login credentials so we can troubleshoot?

    http://www.nextgen-gallery.com/report-bug/

  5. solo013
    Member
    Posted 8 months ago #

    New uploads didn't work either. The / is present in the setting, and even if taken away is auto added to the setting field.

    It's almost as something is using stripslashes() on the $Path & $File variables. I've been searching through the code of every file for anything I thought could cause it, but haven't found anything that looks wrong.

    This is on a nature photography site with over 2000 photos. I have upgraded to 2.0.7 fine on 4 other sites that are on the same domain as sub-domains. It's just the main domain www. site that won't work right. Since 4 other sites on the same server work under sub-domains it's really baffling me. Unfortunately I can't supply login credentials. However, I'm willing to try and report the outcome of any test or solutions that are possible on the server.

  6. octuss
    Member
    Posted 8 months ago #

    Hi,

    how can it be resolved when it is not :)

    I've got the same problem.. my paths are like:

    http://www.domain.ext/wp-contentgallerytynk-tradycyjnythumbsthumbs_dsc05228.jpg

    and when I add the slash/ manually the image appears, so all files are correctly uploaded.

    Anyone have any idea how to fix that ?

  7. octuss
    Member
    Posted 8 months ago #

    Hi,

    ok, going back to ver.1.9.13 solves the problem for now... but I won;t update the plugin until it's fixed in ver.2

    Regards,
    octuss

  8. solo013
    Member
    Posted 8 months ago #

    Wanted to update to say this is still broken in 2.0.11. It has not been resolved despite the thread being marked as resolved.

  9. solo013
    Member
    Posted 7 months ago #

    Still broken in 2.0.21

  10. solo013
    Member
    Posted 7 months ago #

    Still broken in 2.0.23

Reply

You must log in to post.

About this Plugin

About this Topic

Tags