WordPress.org

Ready to get started?Download WordPress

Forums

WP Socializer
[resolved] Patches for mixed content, JS errors, and Facebook/IE compatability issues (2 posts)

  1. tomdxw
    Member
    Posted 1 year ago #

    Hi,

    Thanks for making this great plugin, we use it on one of our client's sites.

    There are three patches in this gist: https://gist.github.com/tomdxw/5271631

    0001-Mixed-content.patch - our client site uses HTTPS, and thus all the assets it includes must also be delivered over HTTPS otherwise various warnings and errors appear depending on the browser.

    0002-JavaScript-errors.patch - I didn't investigate the underlying causes here, I just prevented the error from occurring.

    0003-Use-Facebook-Like-iframe-instead-of-FBML.patch - I don't know what versions of IE you officially support, but if you use IE7 and there's an FBML Facebook Like button on the page, sometimes it will append ?fb_xd_fragment to the URL, so I substituted the iframe Like button which doesn't have that problem.

    Thanks,
    Tom Adams,
    dxw

    http://wordpress.org/extend/plugins/wp-socializer/

  2. vaakash
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    Thanks for using my plugin.

    I'm planning to implement the "https" support for the plugin officially in v2.5 of the plugin, which is yet to be updated.

    For the javascript patch, I dont know why you made sme changes. It works properly in all browsers and no users reported any error in it. If you found any specific error, please mention it.

    Facebook iframe button cannot be implemented because, "iframe" doesn't support the "send" button. Only the FBML code supports both like and send buttons. So on designing for a large scale, it is good to use the FBML rather than the less featured iframe version.

    Thanks for your time and effort on making some modifications and giving your idea.

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags