WordPress.org

Ready to get started?Download WordPress

Forums

CKEditor For WordPress
Pasting tables from word loses formatting -- but used to work (13 posts)

  1. osu9400
    Member
    Posted 3 years ago #

    To get the rich formatting I need, I create a table in Word, then use CKEdit's "paste from word" icon. This used to work. It wasn't ideal, but it worked. Now, this isn't working. When I paste form word, the content is there but all the table formatting and colors are gone.

    Has anyone else tried this?

    I tried both Chrome and IE9 -- same result. I did an auto upgrade from WP 3.1.2 to 3.1.3 today. I'm not sure that would impact this or not, but now I have no way of reverting to test.

  2. dczepierga
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    Do u remember in which version before it works?
    It would be really helpful information...

    Greetings

  3. osu9400
    Member
    Posted 3 years ago #

    It worked with the current version of ckeditor and WP 3.1.2

  4. dczepierga
    Member
    Plugin Author

    Posted 3 years ago #

    Could u try to reproduce this in http://ckeditor.com/demo ?

    Greetings

  5. osu9400
    Member
    Posted 3 years ago #

    Same behavior in the demo site. When I create a rich table in word, "paste from word" it strips all formatting and pastes only black/white tables. I tried both IE9 and Chrome.

    In chrome, I get a dialog box (due to security settings) to paste into and this box seems to keep most of my formatting and colors. When I click OK, the formatting goes away.

  6. michal
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,
    @osu9400 so this is not plugin for wordpress but CKEditor library issue. I will report this to deveolopers of CKEditor.

  7. osu9400
    Member
    Posted 3 years ago #

    Can you reproduce the same thing?

  8. michal
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,
    @osu9400

    Same behavior in the demo site

    If you checked this behaviour on demo site as you wrote, so this is CKEditor library issue. I wrote about this issue to developer of CKEditor, so they can check this.

  9. michal
    Member
    Plugin Author

    Posted 3 years ago #

    @osu9400 try use these options for CKEditor:

    config.pasteFromWordRemoveFontStyles=false;
    config.pasteFromWordRemoveStyles=false;

    you can add it in ckeditor.config.js file or by adding it File Editor settings for CKEditor in WordPress admin.

  10. osu9400
    Member
    Posted 3 years ago #

    That fixed it!! Why isn't that a default setting? Thanks.

  11. michal
    Member
    Plugin Author

    Posted 3 years ago #

    Why isn't that a default setting?

    This is design decision of CKEditor developers.
    I think that more people wish to have nice, clear code after pasting from Word and this is the reason why its done this way. But this is only my opinion. :)

  12. osu9400
    Member
    Posted 2 years ago #

    I'm having the same issue again. I had to rebuild my blog and didn't have my plugins backed up. I added the two lines in the body of this file:

    ./wp-content/plugins/ckeditor-for-wordpress/ckeditor.config.js

    it looks like this:

    CKEDITOR.editorConfig = function(config) {
    	config.resize_minWidth = 450;
             config.pasteFromWordRemoveFontStyles=false;
             config.pasteFromWordRemoveStyles=false;
    ...
    ...

    Is that correct?

  13. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @osu9400 it looks good for me.
    The best way to check is just use editor after configuration settings saving and check if all works as you expected ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic