WordPress.org

Ready to get started?Download WordPress

Forums

Hide My Site
Password request for every page? (24 posts)

  1. jenrstretch
    Member
    Posted 11 months ago #

    Great plugin!

    However, every time I click on another page, it's prompting me to enter the password? Is that intentional? I'd like to bypass that and only have to enter it once per session, and not once per page.

    http://wordpress.org/plugins/hide-my-site/

  2. ClevelandWebDeveloper
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Jen,

    You should only have to enter the password one time.

    The plugin uses cookies to keep you logged in once you enter the correct password. Could it be that you don't have cookies enabled?

  3. houseofstrauss
    Member
    Posted 9 months ago #

    I have the same problem ... requires a login for each new url clicked on my site. Checked and confirmed cookies are allowed (see below). Tried on Chrome and ie, same problem. NOTE, if I login as an admin, there is no problem.

    here is my cookie found on chrome
    Name: hide_my_site-access
    Content: 1

    I set it for 365 days.

  4. ClevelandWebDeveloper
    Member
    Plugin Author

    Posted 9 months ago #

    Thanks for letting me know. Not sure why this is happening for you. If you want to send me a link over to your site, along with your hide my site password, I would be willing to look into it more. You can contact me direct via the form on my website http://www.clevelandwebdeveloper.com/contact/

    Thanks,
    Justin

  5. houseofstrauss
    Member
    Posted 9 months ago #

    Thanks for your reply. Interestingly, I reset the duration for 20 days instead of 365 and it began to work ok.

  6. paceman
    Member
    Posted 5 months ago #

    Thanks for the posts, I am having the some complaints about this issue - not having experienced it myself on Mac nor PC. However, the setting was to "stay logged in for 1 day" -- so I've updated the plugin and set to 20 days instead, let's see if this resolves it...

  7. tmrmarketing
    Member
    Posted 5 months ago #

    I want to install this while I'm developing the website. After I'm done can I uninstall the plugin without any issues?

  8. ClevelandWebDeveloper
    Member
    Plugin Author

    Posted 5 months ago #

    tmrmarketing,
    This should be posted as a new topic, but good question. The plugin doesn't make any permanent changes to your site, so yes when you uninstall it your site will go back to normal. You can also disable password protection via the hide my site settings page.

  9. Big Mac
    Member
    Posted 5 months ago #

    My site too has suddenly started asking for the password for every page. It didn't do that previously, so I suspect that updating to v1.2 a couple of days ago caused it?

    Ah! Duration has always been set to 10 days, but I see other people suggesting that changing it could solve the problem...so I tried that and it did! I changed it to 100 days and it's now working fine again.

  10. terri.swiatek@yahoo.com
    Member
    Posted 5 months ago #

    I am having this problem as well on my site.

  11. kmwhcn1980
    Member
    Posted 5 months ago #

    I'm having the same issue on my site at well. I am being forced to ask for my site password with each page

  12. Big Mac
    Member
    Posted 5 months ago #

    Have you tried changing the duration temporarily? As I mentioned, that fixed it for me.

  13. kmwhcn1980
    Member
    Posted 5 months ago #

    Yes, I've changed the duration, tried different browsers; no dice. I'm still having the issues which force me to submit my password on each page. I've also verified that my browsers are not in "incognito" mode. This plugin will rock once the kinks get worked out.

  14. semidivine
    Member
    Posted 5 months ago #

    Same problem for me. I just downloaded it today, I made sure that cookies are enabled, switched from 1 to 10 to 100 days duration and no go. It's a shame, I really needed this plugin.

    Any way we could get the older version of the plugin?

  15. 2ccreative
    Member
    Posted 5 months ago #

    @semidivine- you can! go to http://wordpress.org/plugins/hide-my-site/download/

    I had the same problem today, and the older version 1.1 works!

  16. ClevelandWebDeveloper
    Member
    Plugin Author

    Posted 5 months ago #

    Hey all,

    Thanks for contributing. I'm trying to narrow down this thing one problem at a time. The truth is that you could all be experiencing different issues. The common factor across them all being that the access cookie is not being saved on the users computer when he or she enters the correct password.

    Conflicts may be caused by different hosting environments, other plugins, client browsers which block cookies, and lots of other things - it's impossible to know for sure.

    I would like to be able isolate each problem and then apply a fix to the plugin for each issue.

    In order to do this, I am requesting access to a WordPress admin account on your sites (you can create a temp admin account for me). If any of you are willing to do this, please email login credentials over to info at clevelandwebdeveloper dot com. I will not make any changes to your wordpress site. Instead, I will make a backup copy of your site which I will store locally and use to debug the underlying issue. Once I solve your issue, I will apply the patch to the plugin and keep you all notified here.

    A couple other points -
    When the password is first entered in, this should be done on your homepage (eg http://www.yoursite.com) as opposed to a subpage (eg http://www.yoursite.com/books/mybook). If you enter the password on the homepage, you will have access to any URL that begins with http://www.yoursite.com. If you enter your password on the subpage example above, you will have access to any URL that begins with http://www.yoursite.com/books/mybook. If you then tried to go http://www.yoursite.com or any other page, you would have to enter the password again.

    It seems strange to me that installing the previous version (1.1) should resolve the issue. People had contacted me regarding this issue while 1.1 was out. Also, that part of the code was not changed between 1.1 and 1.2. In any case, it's possible that for some reason that would fix an issue for some people. Please let me know if that worked for you and I can look more into it.

    Thanks to everyone for your help,

    Justin

  17. 2ccreative
    Member
    Posted 5 months ago #

    Hmm...maybe the reason the 1.1 worked (so I thought) was because I had entered the password into the homepage, but could have done it one an inner page when I had 1.2 installed (not sure).

    I've sent you a login for my client's site (in sub-directory while under development). Please let me know if you need anything else. Thanks so much for looking into this for all of us!

  18. vajrasaraswati
    Member
    Posted 4 months ago #

    Hi Justin, great plugin if this problem could be resolved.

    I have exactly the same problem that each page/post requires the password again whereas I'd like to just login once for the whole site.

    As administrator the login once for the whole site works perfectly. It is only a problem for everyone else on different computers!

    I tried different durations for staying logged in, versions 1.2 and 1.1. Still the same problem unfortunately.

    I'm using the genesis framework - don't have a clue if that could be at all relevent.

  19. ClevelandWebDeveloper
    Member
    Plugin Author

    Posted 4 months ago #

    Hi Vaj,

    It doesn't seem likely that there would be a difference between logging in on an admin account vs non admin, because the plugin doesn't take into account whether or not the user is an admin.

    My suggestion, which I have mentioned in a previous message, would be to make sure that visitors are logging in from the homepage. Quote from above:

    One important point to note is that when the password is first entered in, this should be done on your homepage (eg http://www.yoursite.com) as opposed to a subpage (eg http://www.yoursite.com/books/mybook). If you enter the password on the homepage, you will have access to any URL that begins with http://www.yoursite.com. If you enter your password on the subpage example above, you will have access to any URL that begins with http://www.yoursite.com/books/mybook. If you then tried to go to http://www.yoursite.com or any other page, you would have to enter the password again.

    If this doesn't resolve the problem, would you consider setting up a WordPress admin account on your site for me(you can create a temp admin account). If you are willing to do this, please email login credentials over to info at clevelandwebdeveloper dot com.

    This is all assuming that I am able to recreate the problem when I test it out. If I'm not able to recreate the problem (ie if I login once and it works perfectly for the whole site), I won't be able to troubleshoot or solve it.

    Good luck,

    Justin

  20. vajrasaraswati
    Member
    Posted 4 months ago #

    Well now it is working!

    And it definitely was a problem on multiple computers yesterday...

    The only thing I did was some updates on my computer and activated and deactivated this plugin a number of times.

    So I really hope it keeps on working - it's a simple useful plugin.

  21. vajrasaraswati
    Member
    Posted 4 months ago #

    Hi again Justin,

    I had to change my password today and the plugin started asking for the password on every page again.

    I noticed that other people were able to get the plugin working by changing something (eg the duration) etc. Changing something on the settings page seems to either cause or resolve the problem.

    I deactivated and reactivated the plugin a couple of times and it is working again now. This is what I did the first time too.

    Hope this info helps you,

    Vajrasaraswati

  22. ClevelandWebDeveloper
    Member
    Plugin Author

    Posted 4 months ago #

    Hey everyone,

    FYI I just released version 1.3 which should resolve the issue for the vast majority of those who were experiencing the bug that site visitors were receiving password requests on every page. Also, users can now log in from any page - you no longer have to log in from specifically the homepage in order to stay logged in.

    I appreciate everyone who brought this bug to my attention. Hope this resolves the problem for those of you who were still experiencing it. If not, please let me know - it is particularly helpful if you are able to isolate any plugins that conflict with the plugin.

    Thanks,
    Justin

  23. terri.swiatek@yahoo.com
    Member
    Posted 2 weeks ago #

    Hi there, thanks for all your work looking into this. I have just reinstalled the latest version of the plugin and it still seems to be behaving the same way for me. Mayking the user login to every page of the site. I will send you my info. using the form suggested above.

    I am hosted on wpengine with caching enabled I'm not sure if that makes a difference.

  24. ClevelandWebDeveloper
    Member
    Plugin Author

    Posted 2 weeks ago #

    Hello,

    The plugin is not compatible with wpengine because they have automatic caching enabled on all their sites. This conflicts with the intended behavior of the plugin.

    There's no way that I know of to work around this conflict with caching. I plan on adding a notice to the plugin page so that users know it is not compatible with sites that have caching enabled.

    Thanks,
    Justin

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.