WordPress.org

Ready to get started?Download WordPress

Forums

Password Protected Post (11 posts)

  1. jackiefg
    Member
    Posted 10 years ago #

    Can anyone help? I password-protected one of my posts and yet when you type in the password, it doesn't work, it doesn't show you the post.
    I changed the b2template.functions file for the message to read "put in my son's middle name to read this" but if you put in my son's middle name... justin... it doesn't work.
    I then changed the message, thinking that perhaps it didn't accept ' or , and it still didn't work. There's no point in me password protecting the post if nobody can read it.
    Anybody know what I can do about this?

  2. Laughinglizard
    Member
    Posted 10 years ago #

    Jackie, it works for me (toronto community foundation...right?). You must have a cookie set which is causing a problem. Try emptying your cache and clearing your cookies...

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    I cleared all my cookies and it still wouldn't work. But the funny thing I found in the meantime, is if I go to my total stats page, and click on the title of that post, it takes me right to it - doesn't ask for a password or anything, and yet the password will still not work for me.

  4. jackiefg
    Member
    Posted 10 years ago #

    riiiight - now that I cleared all my cookies, I showed up as anonymous :)

  5. jackiefg
    Member
    Posted 10 years ago #

    alrighty then, I'll live with that, as long as it's working. Perhaps I'll try it with another browser too.

  6. jackiefg
    Member
    Posted 10 years ago #

    uhoh, I tried it with IE (I've been using Avant) and it didn't show me a spot for the password at all - it just showed me the post and the title that said "protected:"

  7. southerngal
    Member
    Posted 10 years ago #

    One thing I have found is that once you put your password in, you can see everything, RSS feed, protected posts, archives. I test out a new word by posting a protected post with a new password that only I have. :) Remember it's not a "private" post, it's a protected post. Private is where you and only you can see the post, kinda like draft, but with a password.

  8. nikkiana
    Member
    Posted 10 years ago #

    It's actually quite an easy fix... Go into your Options, then Base Settings, and then remove the trailing slash on your URL, and you will miraculously find that password protected entries work.

  9. lamb
    Member
    Posted 9 years ago #

    erm... some how i tried that but somehow.. it still does not work..
    i'm using nightly 07052004..

  10. OperaManiac
    Member
    Posted 9 years ago #

    avant and IE are 1 and the same things...

  11. etoile
    Member
    Posted 8 years ago #

    Regarding nikkiana's post: no dice. My WP URI is http://www.amanita.net/wordpress and my blog URI is http://journal.amanita.net - no idea if that's related, but you'll notice neither has a trailing slash. I am also using Permalinks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.